aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/proj/APKBUILD10
-rw-r--r--community/proj/fma.patch37
2 files changed, 4 insertions, 43 deletions
diff --git a/community/proj/APKBUILD b/community/proj/APKBUILD
index 1dae18943be..a852081b8fb 100644
--- a/community/proj/APKBUILD
+++ b/community/proj/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=proj
-pkgver=7.1.0
+pkgver=7.1.1
pkgrel=0
_datumgridver=1.8
pkgdesc="PROJ coordinate transformation software library"
@@ -19,7 +19,6 @@ subpackages="
source="
http://download.osgeo.org/proj/proj-$pkgver.tar.gz
http://download.osgeo.org/proj/proj-datumgrid-$_datumgridver.zip
- fma.patch
"
unpack() {
@@ -72,10 +71,9 @@ datumgrid() {
util() {
pkgdesc="Cartographic projection library (utilities)"
- mkdir -p "$subpkgdir/usr/bin"
+ mkdir -p "$subpkgdir/usr"
mv "$pkgdir/usr/bin" "$subpkgdir/usr"
}
-sha512sums="74c83c001442a2336479ab4cd627fdbf20182711f7d62acf325aaff66c32d10fdb33e1d81cff31cff1c56cb641a9d16f7701bf3e88b98401022acd059d4da28f proj-7.1.0.tar.gz
-991206f17348b3de484eb5364d773cd06577057228c2d1a0a1c1658308e2596ca13338a666fa71ddd76d538f23dd5bf21e178fd26a785717edd847a17e5c0cd1 proj-datumgrid-1.8.zip
-81f088973d27b51c1eb1fd7f89d28337a486bf2aeac52f360d3acae6bb172e748d2ddf6a4c4c6d3dc28778ed9507bc1c18d005a1b63631aabb465b4eb3032797 fma.patch"
+sha512sums="9f092318835006ffe864bb54ac456054196d30ff367546b41f1e49a5f1cc99a4b0b19e3d09c0ce7a336d1562df5784805560e7f725380411b1013a6baf90cf56 proj-7.1.1.tar.gz
+991206f17348b3de484eb5364d773cd06577057228c2d1a0a1c1658308e2596ca13338a666fa71ddd76d538f23dd5bf21e178fd26a785717edd847a17e5c0cd1 proj-datumgrid-1.8.zip"
diff --git a/community/proj/fma.patch b/community/proj/fma.patch
deleted file mode 100644
index d311c3b33a6..00000000000
--- a/community/proj/fma.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 7ab3ee73706c128fd82cc497c86229ba05e6df2c Mon Sep 17 00:00:00 2001
-From: Kai Pastor <dg0yt@darc.de>
-Date: Tue, 7 Jul 2020 19:55:05 +0200
-Subject: [PATCH] CMake build: Check "target_clones" before use
-
-gcc's "target_clones" and "ifunc" function attributes rely on
-extensions to the ELF standard. Using them on MinGW causes "error:
-the call requires 'ifunc', which is not supported by this target".
-Amends 5396b72.
----
- src/lib_proj.cmake | 13 ++++++++++++-
- 1 file changed, 12 insertions(+), 1 deletion(-)
-
-diff --git a/src/lib_proj.cmake b/src/lib_proj.cmake
-index abc9cc4be1..59cb957222 100644
---- a/src/lib_proj.cmake
-+++ b/src/lib_proj.cmake
-@@ -303,7 +303,18 @@ source_group("CMake Files" FILES CMakeLists.txt)
- # Embed PROJ_LIB data files location
- add_definitions(-DPROJ_LIB="${CMAKE_INSTALL_PREFIX}/${DATADIR}")
-
--add_definitions(-DTARGET_CLONES_FMA_ALLOWED)
-+# The gcc "target_clones" function attribute relies on an extension
-+# to the ELF standard. It must not be used on MinGW.
-+include(CheckCXXSourceCompiles)
-+set(CMAKE_REQUIRED_QUIET TRUE)
-+check_cxx_source_compiles([[
-+ __attribute__((target_clones("fma","default")))
-+ int clonable() { return 0; }
-+ int main() { return clonable(); }
-+]] TARGET_CLONES_FMA_ALLOWED)
-+if(TARGET_CLONES_FMA_ALLOWED)
-+ add_definitions(-DTARGET_CLONES_FMA_ALLOWED)
-+endif()
-
- #################################################
- ## targets: libproj and proj_config.h