aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/shiboken6/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/shiboken6/APKBUILD b/community/shiboken6/APKBUILD
index e6d32848c58..8a6fc226063 100644
--- a/community/shiboken6/APKBUILD
+++ b/community/shiboken6/APKBUILD
@@ -5,7 +5,7 @@ pkgver=6.2.2
pkgrel=1
pkgdesc="CPython bindings generator for C++ libraries"
url="https://doc.qt.io/qtforpython/shiboken6/"
-arch="all !mips64" # blocked by numpy
+arch="all"
license="GPL-2.0-or-later"
depends_dev="python3-dev"
makedepends="
@@ -20,6 +20,7 @@ makedepends="
py3-numpy-dev
py3-setuptools
qt6-qtbase-dev
+ samurai
"
subpackages="lib$pkgname:libs lib$pkgname-dev py3-$pkgname:py3"
source="
@@ -29,7 +30,7 @@ builddir="$srcdir/pyside-setup-opensource-src-$pkgver"
build() {
export CLANG_INSTALL_DIR=/usr
- cmake -B build sources/shiboken6 \
+ cmake -B build -G Ninja sources/shiboken6 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=None \
-DBUILD_TESTS=OFF \