aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/task/APKBUILD10
-rw-r--r--community/task/musl-fix.patch16
2 files changed, 4 insertions, 22 deletions
diff --git a/community/task/APKBUILD b/community/task/APKBUILD
index 4b62aa6ec5d..918203879f4 100644
--- a/community/task/APKBUILD
+++ b/community/task/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Michał Polański <michal@polanski.me>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=task
-pkgver=2.5.1
-pkgrel=2
+pkgver=2.5.2
+pkgrel=0
pkgdesc="A command-line to-do list manager"
url="https://taskwarrior.org"
arch="all"
@@ -12,8 +12,7 @@ subpackages="$pkgname-doc
$pkgname-bash-completion:bashcomp:noarch
$pkgname-fish-completion:fishcomp:noarch
$pkgname-zsh-completion:zshcomp:noarch"
-source="https://taskwarrior.org/download/task-$pkgver.tar.gz
- musl-fix.patch"
+source="https://github.com/GothenburgBitFactory/taskwarrior/releases/download/v$pkgver/task-$pkgver.tar.gz"
build() {
cmake . \
@@ -53,5 +52,4 @@ zshcomp() {
"$subpkgdir"/usr/share/zsh/site-functions/_$pkgname
}
-sha512sums="ec17e5cefff55ecd2c1cb717801c02683d94030906c8d86450c3c79c0bc5a18d82559a5e9e26a91411a1025a241b78ddbc1de51cafc1a2dd531e8229e5e61c10 task-2.5.1.tar.gz
-f82f9883ef6c885635890453fbb5c1dc4d4bf4b69926962a643bcaeadeb80874200329c3916b9796d26fd5f28eb9ad20f50fe7e4adc9f9ca635aa4b50be81911 musl-fix.patch"
+sha512sums="dcc44ba7dde1bcf26030cd48f9edb0b4e567269bc6e065bd66b97b46bf8b442df908a9c71aa2c65b382352452fec41a4fdafa1492f5fe0faf5adf03b4ffd5755 task-2.5.2.tar.gz"
diff --git a/community/task/musl-fix.patch b/community/task/musl-fix.patch
deleted file mode 100644
index 54a5167d697..00000000000
--- a/community/task/musl-fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/src/TLSClient.cpp b/src/TLSClient.cpp
-index c67ed44..72da081 100644
---- a/src/TLSClient.cpp
-+++ b/src/TLSClient.cpp
-@@ -36,11 +36,7 @@
- #include <string.h>
- #include <sys/socket.h>
- #include <arpa/inet.h>
--#if (defined OPENBSD || defined SOLARIS || defined NETBSD)
- #include <errno.h>
--#else
--#include <sys/errno.h>
--#endif
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netdb.h>