aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/open-vm-tools/0011-gnu-ucontext.patch33
-rw-r--r--main/open-vm-tools/APKBUILD6
2 files changed, 32 insertions, 7 deletions
diff --git a/main/open-vm-tools/0011-gnu-ucontext.patch b/main/open-vm-tools/0011-gnu-ucontext.patch
index 3f9161a0946..2a01ad7c8d1 100644
--- a/main/open-vm-tools/0011-gnu-ucontext.patch
+++ b/main/open-vm-tools/0011-gnu-ucontext.patch
@@ -1,14 +1,14 @@
-From 2d57a974d9305fac9c18e2f34a04b4d0c204b8fb Mon Sep 17 00:00:00 2001
+From 4d50e19c0d8e5e082fc90aaa8b810e15af5499d1 Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Wed, 18 Nov 2015 10:27:51 +0000
Subject: [PATCH 11/11] gnu-ucontext
---
- open-vm-tools/lib/include/sigPosixRegs.h | 6 +++---
- 1 file changed, 3 insertions(+), 3 deletions(-)
+ open-vm-tools/lib/include/sigPosixRegs.h | 24 ++++++++++++------------
+ 1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/open-vm-tools/lib/include/sigPosixRegs.h b/open-vm-tools/lib/include/sigPosixRegs.h
-index 08ee2c6..b397260 100644
+index 08ee2c6..a880142 100644
--- a/open-vm-tools/lib/include/sigPosixRegs.h
+++ b/open-vm-tools/lib/include/sigPosixRegs.h
@@ -33,7 +33,7 @@
@@ -38,6 +38,31 @@ index 08ee2c6..b397260 100644
#ifdef __x86_64__
#define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_RAX])
#define SC_EBX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_RBX])
+@@ -214,15 +214,15 @@
+ #define SC_R14(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_R14])
+ #define SC_R15(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_R15])
+ #else
+-#define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EAX])
+-#define SC_EBX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EBX])
+-#define SC_ECX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[ECX])
+-#define SC_EDX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EDX])
+-#define SC_EDI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EDI])
+-#define SC_ESI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[ESI])
+-#define SC_EBP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EBP])
+-#define SC_ESP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[ESP])
+-#define SC_EIP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[EIP])
++#define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EAX])
++#define SC_EBX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EBX])
++#define SC_ECX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_ECX])
++#define SC_EDX(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EDX])
++#define SC_EDI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EDI])
++#define SC_ESI(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_ESI])
++#define SC_EBP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EBP])
++#define SC_ESP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_ESP])
++#define SC_EIP(uc) ((unsigned long) (uc)->uc_mcontext.gregs[REG_EIP])
+ #endif
+ #elif defined(ANDROID_X86)
+ #define SC_EAX(uc) ((unsigned long) (uc)->uc_mcontext.eax)
--
2.6.3
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index 4c3ee54fe83..0f279781a08 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -109,7 +109,7 @@ b102e760b68521f95068956e2324207c 0004-Use-configure-test-for-struct-timespec.pa
863372a41921f22d4b74a728a0821111 0008-Use-configure-test-for-sys-stat.h-include.patch
3a92d0642f43ef6343a3525ed2b521d1 0009-Rename-poll.h-to-vm_poll.h.patch
87bfbfc96d0f7ff25f224af23eafc666 0010-Add-support-for-building-with-system-libtirpc.patch
-b303601e7b129a4dee22b1c3ae09e7a3 0011-gnu-ucontext.patch
+657f988c96f1b8edf082fbf70e5172e8 0011-gnu-ucontext.patch
d666cfe7f779f9cb6b5c2260f6c50b54 open-vm-tools.initd"
sha256sums="8765784d85e4a39b08f1cbc2fb9bbb920027d5fa0abb9b99cec4a886a793ad94 open-vm-tools-10.0.0-3000743.tar.gz
d33a60fd3ec63d677d13997ba811e901fa4096a5b883ffae6669dd3ce91ccf5e 0001-lib-misc-Recognize-Alpine-Linux.patch
@@ -122,7 +122,7 @@ d4b2edf7be206dde75ca778599918bd6e01f148b12fe5f8a0a90b49dfd98eaf5 0004-Use-confi
40d8ccdb5ce1f5721942c7f1ace1573277e2ee96b9fbb82c6f197edba7f644cb 0008-Use-configure-test-for-sys-stat.h-include.patch
f080c651e75e9315c5b698646a7faf46a6af835189f49f045e3f1a930d5f621c 0009-Rename-poll.h-to-vm_poll.h.patch
58d062fb1fc148700dac17b2681cb4967ada5a1caac43fbb249f13258d93be37 0010-Add-support-for-building-with-system-libtirpc.patch
-f3ea30dd393608c1f7ea4db8ea2843bc078a7f31a40867ff35de83288fa78a09 0011-gnu-ucontext.patch
+6359cf80de58e9d3988e3ebcbc8140e9074dac6cba9d73b6d3bfc1ce871ac5a5 0011-gnu-ucontext.patch
5b824642ecf298136d39bc40ed25b4d62e1a83ecbdc6b3fe428c520c95f65479 open-vm-tools.initd"
sha512sums="25428a4982fa19208f915fd58067a5aa9a8427b2ff8c3f06889194cdd4792489911232c3cd94ea54f5000c47ca915debd33ee0441579adf50f183b74def5cd45 open-vm-tools-10.0.0-3000743.tar.gz
87ab7df83f512cf5f1ff6bf68546bd3d72a82e7f60f35ce795db6d6105b1178c85dada2beaddd32f870b81e6af4bf907b3a6fca241b33fdee53864bbeb5863ce 0001-lib-misc-Recognize-Alpine-Linux.patch
@@ -135,5 +135,5 @@ c68eefd71202cf76f97f6148675b1241a7ad812343b133e1ceb1047c5c2d5d6a3a4997663a6a7c5b
db9251502ca05cc3ddb111ee192300897615c30b1e17a9a1f62266bba687b7216d9a4d824b9ff61811c3750a4d733dd8fa9a548f1c455893eccbb10fdaec232f 0008-Use-configure-test-for-sys-stat.h-include.patch
b873864da2073e57cc7e1dad6b48200ad0b931d9448a60273e55bb2d44cb34c2eb6b1a2346c1708791e0add81a70d487966f2270a2bdf163cdfa37d38a2c0926 0009-Rename-poll.h-to-vm_poll.h.patch
d2acbc98b79e0a41545443c1195807034b37083a6e7160d74af1173acd6a2d6e14a8e5f909bd17db80c0c93e1d8f34d7278902bd272b672dae412e7cb504517e 0010-Add-support-for-building-with-system-libtirpc.patch
-fafe0fe92133ac385121192781fc519a4c66945a46d4a7f4ddfb679c7ce4fd869023ff4c736da367bf83b3664dcacf3c1000e8e27d2e44b210e25eaa8560a370 0011-gnu-ucontext.patch
+09bb960aff0bcc94df9782b1c5b81db34f8f720421dfed36d80158e877813214871a525ef9c0df78f6072dcd2d2b97734496e9c2a4c4e783d81e3d2f457b3920 0011-gnu-ucontext.patch
c675323a823b3069a281d1b2c1dedccd9d9959e36cffb4763ab72fcf7e828fb1a048a20e005c15a46697a98a61e073bcd778db427a6f77c7b24ac20133f95695 open-vm-tools.initd"