aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/mate-common/APKBUILD31
1 files changed, 10 insertions, 21 deletions
diff --git a/community/mate-common/APKBUILD b/community/mate-common/APKBUILD
index 10ec46880fa..7e4a9cd4e1d 100644
--- a/community/mate-common/APKBUILD
+++ b/community/mate-common/APKBUILD
@@ -2,28 +2,14 @@
# Maintainer: Alan Lacerda <alacerda@alpinelinux.org>
pkgname=mate-common
pkgver=1.18.0
-pkgrel=0
+pkgrel=1
pkgdesc="Common scripts and macros"
url="http://mate-desktop.org/"
arch="noarch"
license="GPLv3+"
-depends=""
-depends_dev=""
-makedepends=""
-install=""
subpackages="$pkgname-doc"
source="http://pub.mate-desktop.org/releases/${pkgver%.*}/$pkgname-$pkgver.tar.xz"
-
-_builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$_builddir"
@@ -31,15 +17,18 @@ build() {
--build=$CBUILD \
--host=$CHOST \
--sysconfdir=/etc \
- --prefix=/usr \
- || return 1
- make || return 1
+ --prefix=/usr
+ make
+}
+check() {
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="${pkgdir}" install || return 1
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
}
sha512sums="cdc8d39a78ebb1a0fb0d8179814ce59691006a21cb10d78b818cf62a8f42c89d01c9126e93b5fa3b7ac27adce52d3a2512ac2fb63c41e6c5a698a767e9176563 mate-common-1.18.0.tar.xz"