aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/dnscrypt-proxy/APKBUILD6
-rw-r--r--community/dnscrypt-proxy/config-full-paths.patch25
2 files changed, 24 insertions, 7 deletions
diff --git a/community/dnscrypt-proxy/APKBUILD b/community/dnscrypt-proxy/APKBUILD
index 6d7041cf8f6..dd501b9ae91 100644
--- a/community/dnscrypt-proxy/APKBUILD
+++ b/community/dnscrypt-proxy/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Ian Bashford <ianbashford@gmail.com>
# Maintainer: Ian Bashford <ianbashford@gmail.com>
pkgname=dnscrypt-proxy
-pkgver=2.0.23
+pkgver=2.0.25
pkgrel=0
pkgdesc="A tool for securing communications between a client and a DNS resolver"
url="https://dnscrypt.info"
@@ -54,8 +54,8 @@ setup() {
install -m755 -D "$srcdir"/$pkgname.setup "$subpkgdir"/usr/sbin/setup-dnscrypt
}
-sha512sums="d4eeaf20a397c8aed08a7a91a720637bb49395488eb1f7ab4a52ca8832d3e0b98fb320b86ca30ad19e1e3504e226379e5d325891a68624532493fc4796959462 dnscrypt-proxy-2.0.23.tar.gz
+sha512sums="74a47b013e15cbdcf8691bf3618cce40149f9832f6fc4c2cbfb6af2a72b4ecb52b068a150999771a77fcf4fdb49c64dabd127c5101ae29fb86723bc30c946133 dnscrypt-proxy-2.0.25.tar.gz
e0a72d39d47dc24b889d08beedbd9fdf21615f42fbab79980debdfd2c3feaa83dc3f776351f7dd13533cc85905ce4e01812e4ff8a80a9ccc0b21e9db7d6cb232 dnscrypt-proxy.initd
c001ae39da1b2db71764cab568f9ed18e4de0cea3d1a4e7bd6dd01a5668b81a888ea9eef99de6beac08857ad7f8eb1a32d730e946ac3563e4dcfa27147e35052 dnscrypt-proxy.confd
66dd43d84117a0151ae41f34d82b716760382a5a491424bf6418228ffd21f0dfbc88e34cc5074e11f97f006335d97b85367bb9ab1d96747a48e893c022ad52d0 dnscrypt-proxy.setup
-c8167dabea1574a2caa23f2b6f59870f4a00b5162b91d0b9deb21eee831e970b39370255f701c1cfee5c31d35904cdf61dbe666381f9c791223ef6ae35fe26bb config-full-paths.patch"
+28eb03f04b7fe8fceff4c9ff03b0f01b45c0a44fd32d38a7cb34b87ea13a801b046d7d81d3e0522cad37c0cb402999739525947477a5fd65f1c0bfd250527e56 config-full-paths.patch"
diff --git a/community/dnscrypt-proxy/config-full-paths.patch b/community/dnscrypt-proxy/config-full-paths.patch
index 3b0258fd3f9..841afbee5a8 100644
--- a/community/dnscrypt-proxy/config-full-paths.patch
+++ b/community/dnscrypt-proxy/config-full-paths.patch
@@ -1,9 +1,9 @@
diff --git a/./dnscrypt-proxy.toml b/dnscrypt-proxy/dnscrypt-proxy.toml
new file mode 100644
-index 0000000..cabf679
+index 0000000..d1f55b0
--- /dev/null
+++ b/dnscrypt-proxy/dnscrypt-proxy.toml
-@@ -0,0 +1,530 @@
+@@ -0,0 +1,547 @@
+
+##############################################
+# #
@@ -124,10 +124,15 @@ index 0000000..cabf679
+refused_code_in_responses = false
+
+
-+## Load-balancing strategy: 'p2' (default), 'ph', 'fastest' or 'random'
++## Load-balancing strategy: 'p2' (default), 'ph', 'first' or 'random'
+
+# lb_strategy = 'p2'
+
++## Set to `true` to constantly try to estimate the latency of all the resolvers
++## and adjust the load-balancing parameters accordingly, or to `false` to disable.
++
++# lb_estimator = true
++
+
+## Log level (0-6, default: 2 - 0 is very verbose, 6 only contains fatal errors)
+
@@ -204,10 +209,22 @@ index 0000000..cabf679
+## initializing the proxy.
+## Useful if the proxy is automatically started at boot, and network
+## connectivity is not guaranteed to be immediately available.
-+## Use 0 to disable.
++## Use 0 to not test for connectivity at all,
++## and -1 to wait as much as possible.
+
+netprobe_timeout = 60
+
++## Address and port to try initializing a connection to, just to check
++## if the network is up. It can be any address and any port, even if
++## there is nothing answering these on the other side. Just don't use
++## a local address, as the goal is to check for Internet connectivity.
++## On Windows, a datagram with a single, nul byte will be sent, only
++## when the system starts.
++## On other operating systems, the connection will be initialized
++## but nothing will be sent at all.
++
++netprobe_address = "9.9.9.9:53"
++
+
+## Offline mode - Do not use any remote encrypted servers.
+## The proxy will remain fully functional to respond to queries that