aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/boost/APKBUILD22
-rw-r--r--main/boost/boost-1.41.0-parameter-needs-python.patch106
-rw-r--r--main/boost/boost-uclibc-thread.patch11
-rw-r--r--main/boost/random-Jamfile15
4 files changed, 5 insertions, 149 deletions
diff --git a/main/boost/APKBUILD b/main/boost/APKBUILD
index 32bf14e8461..2a2c65dc361 100644
--- a/main/boost/APKBUILD
+++ b/main/boost/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=boost
-pkgver=1.43.0
+pkgver=1.45.0
_x=${pkgver%%.*} # strip .y.z
_y=${pkgver%.*} # strip .z
@@ -8,7 +8,7 @@ _y=${_y#*.} # strip x.
_z=${pkgver##*.} # strip x.y.
_ver=${_x}_${_y}_${_z}
-pkgrel=3
+pkgrel=0
pkgdesc="Free peer-reviewed portable C++ source libraries"
url="http://www.boost.org/"
arch="x86 x86_64"
@@ -35,9 +35,7 @@ $pkgname-wave
$pkgname-wserialization
"
source="http://downloads.sourceforge.net/$pkgname/${pkgname}_$_ver.tar.gz
- boost-1.41.0-parameter-needs-python.patch
- boost-uclibc-thread.patch
- random-Jamfile"
+ "
_builddir="$srcdir"/${pkgname}_${_ver}
prepare() {
@@ -48,13 +46,6 @@ prepare() {
patch -p1 -i "$i" || return 1
done
- # add support for /dev/urandom
- mkdir -p libs/random/build
- cp "$srcdir"/random-Jamfile libs/random/build/Jamfile.2
- sed -i -e 's/#ifdef __linux__/#if 1/' \
- libs/random/src/random_device.cpp \
- || return 1
-
# create user-config.jam
cat > user-config.jam <<__EOF__
@@ -82,7 +73,7 @@ _options="--user-config=\"$_builddir/user-config.jam\"
build() {
msg "Building bjam"
export BOOST_ROOT="$_builddir"
- cd "$_builddir"/tools/jam/src
+ cd "$_builddir"/tools/build/v2/engine/src
CC= ./build.sh cc || return 1
_bindir="bin.linuxx86"
[ "${CARCH}" = "x86_64" ] && _bindir="bin.linuxx86_64"
@@ -142,7 +133,4 @@ wave() { _mvlib wave; }
wserialization() { _mvlib wserialization; }
-md5sums="734565ca4819bf04bd8e903e116c3fb1 boost_1_43_0.tar.gz
-83dbee9d7291a0f322fd2b8936aeace7 boost-1.41.0-parameter-needs-python.patch
-7ea3caa231764eca4522ae303939214d boost-uclibc-thread.patch
-1d43f6ee1fc426f1ddcb4aafc6b77b9b random-Jamfile"
+md5sums="739792c98fafb95e7a6b5da23a30062c boost_1_45_0.tar.gz"
diff --git a/main/boost/boost-1.41.0-parameter-needs-python.patch b/main/boost/boost-1.41.0-parameter-needs-python.patch
deleted file mode 100644
index 016995fccc9..00000000000
--- a/main/boost/boost-1.41.0-parameter-needs-python.patch
+++ /dev/null
@@ -1,106 +0,0 @@
---- a/boost/parameter/aux_/maybe.hpp 2008-03-22 21:45:55.000000000 +0000
-+++ b/boost/parameter/aux_/maybe.hpp.new 2009-10-22 03:55:24.000000000 +0000
-@@ -2,20 +2,41 @@
- // subject to the Boost Software License, Version 1.0. (See accompanying
- // file LICENSE_1_0.txt or copy at http://www.boost.org/LICENSE_1_0.txt)
-
--#ifndef BOOST_PARAMETER_MAYBE_060211_HPP
--# define BOOST_PARAMETER_MAYBE_060211_HPP
-+//
-+// 2009.10.21 TDS remove depenency on boost::python::detail::referent_storage
-+//
-+#ifndef BOOST_PARAMETER_MAYBE_091021_HPP
-+# define BOOST_PARAMETER_MAYBE_091021_HPP
-
- # include <boost/mpl/if.hpp>
- # include <boost/mpl/identity.hpp>
- # include <boost/type_traits/is_reference.hpp>
- # include <boost/type_traits/add_reference.hpp>
- # include <boost/optional.hpp>
--# include <boost/python/detail/referent_storage.hpp>
-+# include <boost/aligned_storage.hpp>
- # include <boost/type_traits/remove_cv.hpp>
- # include <boost/type_traits/add_const.hpp>
-
- namespace boost { namespace parameter { namespace aux {
-
-+template <class T> struct referent_size;
-+
-+template <class T>
-+struct referent_size<T&>
-+{
-+ BOOST_STATIC_CONSTANT(std::size_t, value = sizeof(T));
-+};
-+
-+// A metafunction returning a POD type which can store U, where T ==
-+// U&. If T is not a reference type, returns a POD which can store T.
-+template <class T>
-+struct referent_storage
-+{
-+ typedef typename boost::aligned_storage<
-+ referent_size<T>::value
-+ >::type type;
-+};
-+
- struct maybe_base {};
-
- template <class T>
-@@ -33,8 +54,8 @@
- BOOST_DEDUCED_TYPENAME remove_reference<reference>::type
- >::type non_cv_value;
-
-- explicit maybe(T value)
-- : value(value)
-+ explicit maybe(T value_)
-+ : value(value_)
- , constructed(false)
- {}
-
-@@ -48,28 +69,28 @@
- this->destroy();
- }
-
-- reference construct(reference value) const
-+ reference construct(reference value_) const
- {
-- return value;
-+ return value_;
- }
-
- template <class U>
-- reference construct2(U const& value) const
-+ reference construct2(U const& value_) const
- {
-- new (m_storage.bytes) non_cv_value(value);
-+ new (m_storage.address()) non_cv_value(value_);
- constructed = true;
-- return *(non_cv_value*)m_storage.bytes;
-+ return *(non_cv_value*)m_storage.address();
- }
-
- template <class U>
-- reference construct(U const& value) const
-+ reference construct(U const& value_) const
- {
-- return this->construct2(value);
-+ return this->construct2(value_);
- }
-
- void destroy()
- {
-- ((non_cv_value*)m_storage.bytes)->~non_cv_value();
-+ ((non_cv_value*)m_storage.address())->~non_cv_value();
- }
-
- typedef reference(maybe<T>::*safe_bool)() const;
-@@ -87,7 +108,9 @@
- private:
- boost::optional<T> value;
- mutable bool constructed;
-- mutable typename boost::python::detail::referent_storage<
-+
-+
-+ mutable typename referent_storage<
- reference
- >::type m_storage;
- };
diff --git a/main/boost/boost-uclibc-thread.patch b/main/boost/boost-uclibc-thread.patch
deleted file mode 100644
index e9e6b79e107..00000000000
--- a/main/boost/boost-uclibc-thread.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./libs/thread/src/pthread/thread.cpp.orig
-+++ ./libs/thread/src/pthread/thread.cpp
-@@ -380,7 +380,7 @@
- {
- #if defined(PTW32_VERSION) || defined(__hpux)
- return pthread_num_processors_np();
--#elif defined(_GNU_SOURCE)
-+#elif defined(_GNU_SOURCE) && !defined(__UCLIBC__)
- return get_nprocs();
- #elif defined(__APPLE__) || defined(__FreeBSD__)
- int count;
diff --git a/main/boost/random-Jamfile b/main/boost/random-Jamfile
deleted file mode 100644
index 5cb6f6bcd9b..00000000000
--- a/main/boost/random-Jamfile
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright (c) 2006 Tiziano Mueller
-#
-# Use, modification and distribution of the file is subject to the
-# Boost Software License, Version 1.0.
-# (See at http://www.boost.org/LICENSE_1_0.txt)
-
-
-project boost/random
- : source-location ../ ;
-
-SOURCES = random_device ;
-
-lib boost_random
- : $(SOURCES).cpp
- : <link>shared:<define>BOOST_RANDOM_DYN_LINK=1 ;