aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/tk/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/tk/APKBUILD b/main/tk/APKBUILD
index 963db465032..57f2411ee07 100644
--- a/main/tk/APKBUILD
+++ b/main/tk/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=tk
pkgver=8.6.10
-pkgrel=0
+pkgrel=1
pkgdesc="GUI toolkit for the Tcl scripting language"
url="http://tcl.sourceforge.net/"
arch="all"
@@ -49,6 +49,10 @@ package() {
}
dev() {
+ # libtk8.6.so is the only library made and it remains in the mainpackage
+ # so depending on the main package automatically is never done
+ # https://gitlab.alpinelinux.org/alpine/aports/issues/11232#note_68789
+ depends_dev="$depends_dev tk=$pkgver-r$pkgrel"
default_dev
cd $pkgdir
for i in $(find . -name '*.c' -o -name '*Config.sh'); do