aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/gdal/APKBUILD2
-rw-r--r--community/py3-matplotlib/APKBUILD3
-rw-r--r--community/py3-opencl/APKBUILD3
-rw-r--r--community/py3-pytools/APKBUILD3
-rw-r--r--community/py3-pyzbar/APKBUILD5
-rw-r--r--community/xpra/APKBUILD3
6 files changed, 13 insertions, 6 deletions
diff --git a/community/gdal/APKBUILD b/community/gdal/APKBUILD
index a746925e1db..28a7f490e2e 100644
--- a/community/gdal/APKBUILD
+++ b/community/gdal/APKBUILD
@@ -5,7 +5,7 @@ pkgver=3.0.4
pkgrel=4
pkgdesc="A translator library for raster and vector geospatial data formats"
url="https://gdal.org/"
-arch="all !s390x !x86 !armhf !armv7"
+arch="all !s390x !x86 !armhf !armv7 !mips !mips64"
license="MIT"
depends_dev="gdal"
makedepends="
diff --git a/community/py3-matplotlib/APKBUILD b/community/py3-matplotlib/APKBUILD
index d3589f2d8a5..7904168c972 100644
--- a/community/py3-matplotlib/APKBUILD
+++ b/community/py3-matplotlib/APKBUILD
@@ -6,7 +6,8 @@ pkgver=3.2.1
pkgrel=0
pkgdesc="Python3 library for plots"
url="https://matplotlib.org"
-arch="all"
+# mips blocked due to py3-numpy
+arch="all !mips !mips64"
license="Python-2.0"
depends="py3-numpy py3-dateutil py3-parsing py3-tz py3-cycler py3-cairo py3-kiwisolver
python3-tkinter"
diff --git a/community/py3-opencl/APKBUILD b/community/py3-opencl/APKBUILD
index a588757ab6f..4caca455d15 100644
--- a/community/py3-opencl/APKBUILD
+++ b/community/py3-opencl/APKBUILD
@@ -6,7 +6,8 @@ pkgver=2019.1.2
pkgrel=0
pkgdesc="Python3 wrapper for OpenCL"
url="https://pypi.python.org/pypi/pyopencl"
-arch="all"
+# mips blocked due to py3-numpy
+arch="all !mips !mips64"
license="MIT"
depends="py3-appdirs py3-decorator py3-numpy py3-six py3-mako py3-pytools"
makedepends="python3-dev py3-setuptools ctags libffi-dev mesa-dev opencl-headers
diff --git a/community/py3-pytools/APKBUILD b/community/py3-pytools/APKBUILD
index 9a90442d2fc..c22ee2b3cb7 100644
--- a/community/py3-pytools/APKBUILD
+++ b/community/py3-pytools/APKBUILD
@@ -6,7 +6,8 @@ pkgrel=0
pkgdesc="Collection of tools for Python3"
options="!check" # Tests required unpackaged dependencies not specified in requires.txt
url="https://github.com/inducer/pytools"
-arch="noarch"
+# mips blocked due to py3-numpy
+arch="noarch !mips !mips64"
license="MIT"
depends="python3 py3-decorator py3-appdirs py3-six py3-numpy"
makedepends="py3-setuptools"
diff --git a/community/py3-pyzbar/APKBUILD b/community/py3-pyzbar/APKBUILD
index 6d8559562e7..fa8faa0d506 100644
--- a/community/py3-pyzbar/APKBUILD
+++ b/community/py3-pyzbar/APKBUILD
@@ -13,12 +13,15 @@ checkdepends="py3-coveralls py3-nose py3-numpy py3-pillow"
source="py3-pyzbar-$pkgver.tar.gz::https://github.com/NaturalHistoryMuseum/pyzbar/archive/v$pkgver.tar.gz"
builddir="$srcdir/pyzbar-$pkgver"
+case "$CARCH" in
+s390x | mips*) options="!check" ;;
+esac
+
build() {
python3 setup.py build
}
check() {
- [ "$CARCH" = s390x ] && return 0
python3 setup.py test
}
diff --git a/community/xpra/APKBUILD b/community/xpra/APKBUILD
index 3fbe73670a2..5de368cced3 100644
--- a/community/xpra/APKBUILD
+++ b/community/xpra/APKBUILD
@@ -5,7 +5,8 @@ pkgver=3.0.8
pkgrel=0
pkgdesc="Xpra is 'screen for X' & allows you to run X programs, usually on a remote host over SSH or encrypted tcp"
url="https://xpra.org"
-arch="all"
+# blocked by numpy
+arch="all !mips !mips64"
license="GPL-2.0-or-later"
depends="
py3-gobject3