aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/imapsync/APKBUILD16
-rw-r--r--community/imapsync/makefile.patch20
2 files changed, 31 insertions, 5 deletions
diff --git a/community/imapsync/APKBUILD b/community/imapsync/APKBUILD
index bc421dc5396..c47b53ce362 100644
--- a/community/imapsync/APKBUILD
+++ b/community/imapsync/APKBUILD
@@ -31,6 +31,11 @@ depends="perl-app-cpanminus
perl-regexp-common
perl-sys-meminfo
perl-term-readkey
+ perl-unicode-string
+ perl-uri
+ procps
+ "
+checkdepends="
perl-test-deep
perl-test-fatal
perl-test-mock-guard
@@ -40,19 +45,19 @@ depends="perl-app-cpanminus
perl-test-requires
perl-test-simple
perl-test-warn
- perl-unicode-string
- perl-uri
- procps
"
makedepends="perl-module-scandeps perl-par-packer"
subpackages="$pkgname-doc"
-source="https://github.com/$pkgname/$pkgname/archive/$pkgname-$pkgver.tar.gz"
+source="https://github.com/$pkgname/$pkgname/archive/$pkgname-$pkgver.tar.gz
+ makefile.patch"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
# NOTE: tests.sh requires authors remote imap password
check() {
cd "$builddir"
+
./imapsync --version
+ make testp # check dependencies
}
package() {
@@ -66,4 +71,5 @@ package() {
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-sha512sums="3953cb29b210c283be3fe72f1e1537594415bd5457b469b801625d6c857b982d2b2b3da9528dd1e6ccc6831c022ce495f7a5eaaea04d228bca374f185344f455 imapsync-1.882.tar.gz"
+sha512sums="3953cb29b210c283be3fe72f1e1537594415bd5457b469b801625d6c857b982d2b2b3da9528dd1e6ccc6831c022ce495f7a5eaaea04d228bca374f185344f455 imapsync-1.882.tar.gz
+c017e2b437865ee83eae6fb66a034b9259720b9cd8bfe79c37e08cd6c1788bb16bba3b96f3861ea0c2ef77cc5a2663c9a6042dbc3434a193c331b4d6c3937b95 makefile.patch"
diff --git a/community/imapsync/makefile.patch b/community/imapsync/makefile.patch
new file mode 100644
index 00000000000..8c040696948
--- /dev/null
+++ b/community/imapsync/makefile.patch
@@ -0,0 +1,20 @@
+Don't run tests on install.
+
+--- a/Makefile
++++ b/Makefile
+@@ -165,7 +165,7 @@
+ W/imapsync.1: imapsync
+ pod2man imapsync > W/imapsync.1
+
+-install: testp W/imapsync.1
++install: W/imapsync.1
+ mkdir -p $(DESTDIR)$(PREFIX)/bin
+ install imapsync $(DESTDIR)$(PREFIX)/bin/imapsync
+ chmod 755 $(DESTDIR)$(PREFIX)/bin/imapsync
+@@ -708,4 +708,4 @@
+ rsync -aHv --delete ./FAQ.d/ ../imapsync_website/FAQ.d/
+ rsync -avH --delete ./doc/ ../imapsync_website/doc/
+ rsync -aHvz --delete ../imapsync_website/ root@ks.lamiral.info:/var/www/imapsync/
+- ssh root@ks.lamiral.info 'apachectl configtest && /etc/init.d/apache2 reload'
+\ No newline at end of file
++ ssh root@ks.lamiral.info 'apachectl configtest && /etc/init.d/apache2 reload'