aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libraw1394/APKBUILD14
1 files changed, 3 insertions, 11 deletions
diff --git a/community/libraw1394/APKBUILD b/community/libraw1394/APKBUILD
index 27430b0d370..602f6e97114 100644
--- a/community/libraw1394/APKBUILD
+++ b/community/libraw1394/APKBUILD
@@ -1,22 +1,16 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=libraw1394
pkgver=2.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Library to provide access to Linux 1394 subsystem"
url="https://sourceforge.net/projects/libraw1394"
arch="all"
-license="LGPL-2.1+"
-depends=
-depends_dev=
+license="LGPL-2.1-or-later"
makedepends="linux-headers"
-install=
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="https://kernel.org/pub/linux/libs/ieee1394/$pkgname-$pkgver.tar.xz"
-
-builddir="$srcdir"/$pkgname-$pkgver
+source="https://kernel.org/pub/linux/libs/ieee1394/libraw1394-$pkgver.tar.xz"
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -29,12 +23,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}