aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/powerdevil/APKBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/community/powerdevil/APKBUILD b/community/powerdevil/APKBUILD
index 6c999e19427..a486fd82ce1 100644
--- a/community/powerdevil/APKBUILD
+++ b/community/powerdevil/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=powerdevil
pkgver=5.21.4
-pkgrel=0
+pkgrel=1
pkgdesc="Manages the power consumption settings of a Plasma Shell"
# armhf blocked by extra-cmake-modules
# s390x blocked by libksysguard
@@ -60,6 +60,9 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
+ # We don't ship systemd
+ rm -r "$pkgdir"/usr/lib/systemd
+
# org_kde_powerdevil has CAP_WAKE_ALARM set and this breaks dbus
# Remove CAP_WAKE_ALARM from org_kde_powerdevil to make it work again
setcap -r "$pkgdir"/usr/lib/libexec/org_kde_powerdevil