aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/lsp-plugins/APKBUILD12
-rw-r--r--testing/lsp-plugins/cflags.patch21
2 files changed, 29 insertions, 4 deletions
diff --git a/testing/lsp-plugins/APKBUILD b/testing/lsp-plugins/APKBUILD
index 1ed9e8032a3..037c86ba2af 100644
--- a/testing/lsp-plugins/APKBUILD
+++ b/testing/lsp-plugins/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: psykose <alice@ayaya.dev>
# Maintainer: psykose <alice@ayaya.dev>
pkgname=lsp-plugins
-pkgver=1.2.1
+pkgver=1.2.2
pkgrel=0
pkgdesc="Collection of free plugins compatible with LADSPA, LV2 and LinuxVST"
url="https://lsp-plug.in"
@@ -10,15 +10,18 @@ license="LGPL-3.0-or-later"
options="!check" # no testsuite
makedepends="
cairo-dev
+ cmd:php
jack-dev
ladspa-dev
libsndfile-dev
+ libxrandr-dev
lv2-dev
mesa-dev
- php8
"
subpackages="$pkgname-doc $pkgname-dev"
-source="https://github.com/sadko4u/lsp-plugins/releases/download/$pkgver/lsp-plugins-src-$pkgver.tar.gz"
+source="https://github.com/sadko4u/lsp-plugins/releases/download/$pkgver/lsp-plugins-src-$pkgver.tar.gz
+ cflags.patch
+ "
builddir="$srcdir/$pkgname"
build() {
@@ -34,5 +37,6 @@ package() {
}
sha512sums="
-7246d60cd34313aa05a9167218d84cfd7a8d839520de44d1cb52e9da4df25a3f76a4cc1af17b5914532f0aa7227071e9b0cc4d9b87cab57d77feb759f26bd461 lsp-plugins-src-1.2.1.tar.gz
+63a1da2007a91db0e9bed97c26de5c5621b429d801b8d0eaf0e8d26aba2a57631824566e2c0ad48ea5943a5050cc40d4328c30427e4986b85d2878773a51dae1 lsp-plugins-src-1.2.2.tar.gz
+d5a8dc5d85ebfa6459a4a529957fd1e63e06af3ad6f4afd506689ff66f38aa1cb60c5ea95542c2314a45cef7be5e4e62e9d7f2e0911afbcdb3f54e2cc5bfd9c6 cflags.patch
"
diff --git a/testing/lsp-plugins/cflags.patch b/testing/lsp-plugins/cflags.patch
new file mode 100644
index 00000000000..cb4c004916a
--- /dev/null
+++ b/testing/lsp-plugins/cflags.patch
@@ -0,0 +1,21 @@
+see https://github.com/sadko4u/lsp-plugins/issues/257
+--- a/make/tools.mk
++++ b/make/tools.mk
+@@ -110,7 +110,7 @@
+ endif
+
+ # Define flags for (cross) build
+-CFLAGS ?= \
++CFLAGS += \
+ $(CFLAGS_EXT) \
+ -fdata-sections \
+ -ffunction-sections \
+@@ -120,7 +120,7 @@
+
+ CDEFS += -DLSP_INSTALL_PREFIX=\\\"$(PREFIX)\\\"
+
+-CXXFLAGS ?= \
++CXXFLAGS += \
+ $(CXXFLAGS_EXT) \
+ -std=c++98 \
+ -fno-exceptions \