aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libsass/APKBUILD9
-rw-r--r--community/libsass/fix-pkgconfig-version.patch16
2 files changed, 22 insertions, 3 deletions
diff --git a/community/libsass/APKBUILD b/community/libsass/APKBUILD
index 7fcd16debf3..5779fa86965 100644
--- a/community/libsass/APKBUILD
+++ b/community/libsass/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Thomas Boerger <thomas@webhippie.de>
pkgname=libsass
pkgver=3.6.3
-pkgrel=0
+pkgrel=1
pkgdesc="C/C++ implementation of a Sass compiler"
options="!check" # No tests are run when make check is run
url="https://sass-lang.com/libsass"
@@ -10,7 +10,9 @@ arch="all"
license="MIT"
makedepends="autoconf automake libtool"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/sass/libsass/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sass/libsass/archive/$pkgver.tar.gz
+ fix-pkgconfig-version.patch
+ "
prepare() {
default_prepare
@@ -31,4 +33,5 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-sha512sums="e290f2045784ba1cf84e87e5bd33129b5452fec1d25da657b084b3561ec76df195a75595248a493dbd85c6a1215ed600332477945922309c021d9e416ebb29ee libsass-3.6.3.tar.gz"
+sha512sums="e290f2045784ba1cf84e87e5bd33129b5452fec1d25da657b084b3561ec76df195a75595248a493dbd85c6a1215ed600332477945922309c021d9e416ebb29ee libsass-3.6.3.tar.gz
+c5dc711ea64a5dea2505b467ba3a6fa34064ec1e83be29e445f6b47aa8f32ffd7f861800bae213cfef60c5bb1c89f303cf3e1edf818369e222a6d2edc458c721 fix-pkgconfig-version.patch"
diff --git a/community/libsass/fix-pkgconfig-version.patch b/community/libsass/fix-pkgconfig-version.patch
new file mode 100644
index 00000000000..f957de424af
--- /dev/null
+++ b/community/libsass/fix-pkgconfig-version.patch
@@ -0,0 +1,16 @@
+diff --git a/version.sh b/version.sh
+index 281de74..22cd96d 100755
+--- a/version.sh
++++ b/version.sh
+@@ -1,10 +1 @@
+-if test "x$LIBSASS_VERSION" = "x"; then
+- LIBSASS_VERSION=`git describe --abbrev=4 --dirty --always --tags 2>/dev/null`
+-fi
+-if test "x$LIBSASS_VERSION" = "x"; then
+- LIBSASS_VERSION=`cat VERSION 2>/dev/null`
+-fi
+-if test "x$LIBSASS_VERSION" = "x"; then
+- LIBSASS_VERSION="[na]"
+-fi
+-echo $LIBSASS_VERSION
++echo 3.6.3