aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/opkg-utils/0001-Makefile-seperate-manpages-and-utils-install.patch45
-rw-r--r--testing/opkg-utils/APKBUILD11
2 files changed, 4 insertions, 52 deletions
diff --git a/testing/opkg-utils/0001-Makefile-seperate-manpages-and-utils-install.patch b/testing/opkg-utils/0001-Makefile-seperate-manpages-and-utils-install.patch
deleted file mode 100644
index 00131f1f92c..00000000000
--- a/testing/opkg-utils/0001-Makefile-seperate-manpages-and-utils-install.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 1e6a96e9573164bfacb1a2fae16de00763bb06da Mon Sep 17 00:00:00 2001
-From: Ryan Barnett <ryanbarnett3@gmail.com>
-Date: Sat, 20 Feb 2021 13:40:05 -0600
-Subject: [PATCH 1/1] Makefile: seperate manpages and utils install
-
-To allow the opkg-utils to be installed separately from the manpages,
-break apart the install step into two install steps: install-utils and
-install-docs
-
-Signed-off-by: Ryan Barnett <ryanbarnett3@gmail.com>
----
- Makefile | 10 +++++++---
- 1 file changed, 7 insertions(+), 3 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 4049654..7b7b8d5 100644
---- a/Makefile
-+++ b/Makefile
-@@ -25,11 +25,13 @@ mandir ?= $(PREFIX)/man
- %.1: %
- pod2man -r "" -c "opkg-utils Documentation" $< $@
-
--all: $(UTILS) $(MANPAGES)
-+all: install
-
--install: all
-+install-utils: $(UTILS)
- install -d $(DESTDIR)$(bindir)
- install -m 755 $(UTILS) $(DESTDIR)$(bindir)
-+
-+install-docs: $(MANPAGES)
- install -d $(DESTDIR)$(mandir)
- for m in $(MANPAGES); \
- do \
-@@ -37,4 +39,6 @@ install: all
- install -m 644 "$$m" $(DESTDIR)$(mandir)/man$${m##*.}; \
- done
-
--.PHONY: install all
-+install: install-utils install-docs
-+
-+.PHONY: install install-utils install-docs all
---
-2.25.1
-
diff --git a/testing/opkg-utils/APKBUILD b/testing/opkg-utils/APKBUILD
index 0759b315dc9..8089fa5724f 100644
--- a/testing/opkg-utils/APKBUILD
+++ b/testing/opkg-utils/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ryan Barnett <ryanbarnett3@gmail.com>
pkgname=opkg-utils
-pkgver=0.4.3
-pkgrel=1
+pkgver=0.4.5
+pkgrel=0
pkgdesc="Helper scripts for use with the opkg package manager"
url="https://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/"
arch="noarch"
@@ -22,9 +22,7 @@ depends="bash
"
makedepends="perl"
subpackages="$pkgname-doc"
-source="https://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/snapshot/opkg-utils-$pkgver.tar.gz
- 0001-Makefile-seperate-manpages-and-utils-install.patch
- "
+source="https://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/snapshot/opkg-utils-$pkgver.tar.gz"
options="!check" # no test suite
package() {
@@ -36,5 +34,4 @@ package() {
make PREFIX=/usr/share DESTDIR="$pkgdir" install-docs
}
-sha512sums="1a8e40ad4d79eb6e63ff3debcc1f97335ef6e65879a39be3394ba08454e42683c8118723c9096118af109ff502d8a0a9433caf233572e375ad675ef25a60d9f6 opkg-utils-0.4.3.tar.gz
-c9f21f1f49a82bfab2c84d301a8e28e1f4346a3ae112330ba1061a4a7e32200a8e1c0be58f90c91598609fe94f7c9afe315a78f31575fff58612b7a4b97c49d9 0001-Makefile-seperate-manpages-and-utils-install.patch"
+sha512sums="819377e8f417d6abac4a74ad3612ca22de68b3f785d0ef912e60f174132335683080936bb20a1dba44d9d717b2cf9c442a9a774ba0a1297504eb695e6dd64df6 opkg-utils-0.4.5.tar.gz"