aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/spice-gtk/APKBUILD12
-rw-r--r--community/spice-gtk/disable-test-relying-on-usb.patch20
-rw-r--r--community/spice-gtk/fix-pkgconfig-version.patch6
3 files changed, 24 insertions, 14 deletions
diff --git a/community/spice-gtk/APKBUILD b/community/spice-gtk/APKBUILD
index 3fb2015f46b..b6eb0bb80f7 100644
--- a/community/spice-gtk/APKBUILD
+++ b/community/spice-gtk/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice-gtk
-pkgver=0.37
-pkgrel=3
+pkgver=0.38
+pkgrel=0
pkgdesc="GTK+ widget for SPICE clients"
url="https://www.spice-space.org/spice-gtk.html"
arch="all"
@@ -38,7 +38,7 @@ makedepends="
options="suid"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang $pkgname-tools
spice-glib:glib"
-source="https://www.spice-space.org/download/gtk/spice-gtk-$pkgver.tar.bz2
+source="https://www.spice-space.org/download/gtk/spice-gtk-$pkgver.tar.xz
disable-test-relying-on-usb.patch
fix-pkgconfig-version.patch
"
@@ -91,6 +91,6 @@ glib() {
"$subpkgdir"/usr/lib/girepository-1.0/
}
-sha512sums="a0a20bc6f25337d86e57fe1fc9586c4cc84457fc8c38cdcc5a728990a69018da0fca3ab5aa63349786b5a7508c82b716c94803eefb3495cffb7df4526db2d029 spice-gtk-0.37.tar.bz2
-fcb2eed3ccfdba422338aa292c56b61d5aa0b83e60feed8b042b44281d0090f7ec82a853332cf5d36338b5cc097031f5af25457866f11f2ed8a4c92f4372b863 disable-test-relying-on-usb.patch
-781ff842527cb23b894c45765035628406f487e4696900561de3d804704bb31f14ccbcd5f48303efcf43734e545643dbb011d3c9dbd46c1962a2307cef138350 fix-pkgconfig-version.patch"
+sha512sums="27b44ac9f0cee2737ce03bb3f47c62fc0ee2402c291c49fc56cffc4ccb63e2cab001a68ba865a6375d82cb38444408d59c68469783ee4279fa818d8682e902f3 spice-gtk-0.38.tar.xz
+49af336eb9c4a785b557b3e0e4e9781bccc9fbfd85d2d98bff6bd57c80d9e49f17b27915c720f49da8670f7ab197496f5a7e2a85cc478a9cb0051b0a11a2bf5f disable-test-relying-on-usb.patch
+0126de8c1dad557d33c3e70c8c281d4515ef54df99ac282046a7b543cfd765fca7b94ed7f1b27ae48f3b62492936feb74e59e5c653f193515d07267497b740d7 fix-pkgconfig-version.patch"
diff --git a/community/spice-gtk/disable-test-relying-on-usb.patch b/community/spice-gtk/disable-test-relying-on-usb.patch
index 4f05b3ff9f9..2a8e2832cc1 100644
--- a/community/spice-gtk/disable-test-relying-on-usb.patch
+++ b/community/spice-gtk/disable-test-relying-on-usb.patch
@@ -4,9 +4,19 @@ index 6c8077622d..9b77e84be9 100644
+++ b/tests/meson.build
@@ -1,7 +1,6 @@
tests_sources = [
- 'util.c',
- 'coroutine.c',
-- 'session.c',
- 'uri.c',
- 'file-transfer.c',
+ 'util.c',
+ 'coroutine.c',
+- 'session.c',
+ 'uri.c',
+ 'file-transfer.c',
]
+@@ -10,9 +9,6 @@
+ tests_sources += 'pipe.c'
+ endif
+
+-if spice_gtk_has_usbredir
+- tests_sources += 'cd-emu.c'
+-endif
+
+ if spice_gtk_has_polkit
+ tests_sources += [
diff --git a/community/spice-gtk/fix-pkgconfig-version.patch b/community/spice-gtk/fix-pkgconfig-version.patch
index bc96843f40c..687e3b43e02 100644
--- a/community/spice-gtk/fix-pkgconfig-version.patch
+++ b/community/spice-gtk/fix-pkgconfig-version.patch
@@ -7,7 +7,7 @@ index 8c6288f..caef2d4 100644
#
project('spice-gtk', 'c',
- version : run_command('build-aux/git-version-gen', '@0@/.tarball-version'.format(meson.source_root()), check : true).stdout().strip(),
-+ version : '0.37',
++ version : '0.38',
license : 'LGPLv2.1',
- meson_version : '>= 0.49')
-
+ meson_version : '>= 0.49',
+ default_options : ['buildtype=debugoptimized',