aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ocaml-findlib/APKBUILD12
-rw-r--r--community/ocaml-findlib/fix-reinstallation-of-num-for-ocaml-4.06.patch49
2 files changed, 56 insertions, 5 deletions
diff --git a/community/ocaml-findlib/APKBUILD b/community/ocaml-findlib/APKBUILD
index 52dcdc3d9f5..22d78bf3b46 100644
--- a/community/ocaml-findlib/APKBUILD
+++ b/community/ocaml-findlib/APKBUILD
@@ -3,17 +3,18 @@
pkgname=ocaml-findlib
_pkgname=findlib
pkgver=1.7.3
-pkgrel=0
+pkgrel=1
pkgdesc="OCaml package manager"
url="http://projects.camlcity.org/projects/findlib.html"
arch="all !x86 !armhf !s390x" # limited by ocaml abuild
license="MIT"
-depends="ocaml"
+depends="ocaml ocaml-runtime"
depends_dev="$pkgname=$pkgver-r$pkgrel"
-makedepends="m4 ncurses-dev"
+makedepends="ocaml-compiler-libs m4 ncurses-dev"
options="textrels"
subpackages="$pkgname-dev $pkgname-doc"
-source="http://download.camlcity.org/download/$_pkgname-$pkgver.tar.gz"
+source="http://download.camlcity.org/download/$_pkgname-$pkgver.tar.gz
+ fix-reinstallation-of-num-for-ocaml-4.06.patch"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
@@ -50,4 +51,5 @@ dev() {
"$subpkgdir"/$sitelib/
}
-sha512sums="5fc8250c123e2f019406be487134523f964668d615b51b216551d74f6ec1999de43aa7babc9c2c75ebb87293b4b8c640548d562a98a6e5a6d7f663432869c886 findlib-1.7.3.tar.gz"
+sha512sums="5fc8250c123e2f019406be487134523f964668d615b51b216551d74f6ec1999de43aa7babc9c2c75ebb87293b4b8c640548d562a98a6e5a6d7f663432869c886 findlib-1.7.3.tar.gz
+07a31d46c102cc645c5f56cd78ba5472ee18a4b1a285ff2f1295fe3333e5562ed5cdae47c070d56635c445e6e3c4f4ba732152b987ac2ffa68c0a77d7b5ba26c fix-reinstallation-of-num-for-ocaml-4.06.patch"
diff --git a/community/ocaml-findlib/fix-reinstallation-of-num-for-ocaml-4.06.patch b/community/ocaml-findlib/fix-reinstallation-of-num-for-ocaml-4.06.patch
new file mode 100644
index 00000000000..41127b6c2dc
--- /dev/null
+++ b/community/ocaml-findlib/fix-reinstallation-of-num-for-ocaml-4.06.patch
@@ -0,0 +1,49 @@
+Patch-Source: https://src.fedoraproject.org/rpms/ocaml-findlib/blob/f28/f/findlib-fix-reinstallation-of-num-for-ocaml-4.06.patch
+
+diff --git a/configure b/configure
+index 6a4a558..3f99074 100755
+--- a/configure
++++ b/configure
+@@ -514,7 +514,10 @@ fi
+
+ # dbm?
+
+-if [ -f "${ocaml_core_stdlib}/dbm.cmi" ]; then
++if [ -f "${ocaml_sitelib}/dbm/META" ]; then
++ echo "dbm: package already present"
++ ldbm=""
++elif [ -f "${ocaml_core_stdlib}/dbm.cmi" ]; then
+ echo "dbm: found"
+ ldbm="dbm"
+ else
+@@ -524,8 +527,12 @@ fi
+
+ # num?
+
+-if [ -f "${ocaml_core_stdlib}/num.cmi" ]; then
+- echo "num: found"
++if [ -f "${ocaml_sitelib}/num/META" ]; then
++ echo "num: package already present"
++ lnum=""
++ numtop=""
++elif [ -f "${ocaml_core_stdlib}/num.cmi" ]; then
++ echo "num: found but not as package"
+ lnum="num num-top"
+ numtop="num-top"
+ else
+diff --git a/doc/README.xml b/doc/README.xml
+index 248483e..0b2b3b5 100644
+--- a/doc/README.xml
++++ b/doc/README.xml
+@@ -110,6 +110,11 @@ configuration files, and library routines in detail.</p>
+ <ul>
+
+ <li>
++ <p><em>git version:</em> Fix reinstallation of "num" for OCaml-4.06.
++ </p>
++ </li>
++
++ <li>
+ <p><em>1.7.3:</em> Fix regarding num-top: this library is now also
+ optional, as num.</p>
+ </li>