aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-pokebase/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-pokebase/APKBUILD b/testing/py3-pokebase/APKBUILD
new file mode 100644
index 00000000000..5305edbbd19
--- /dev/null
+++ b/testing/py3-pokebase/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribberse <bribbers@disroot.org>
+# Maintainer: Bart Ribberse <bribbers@disroot.org>
+pkgname=py3-pokebase
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="A Python wrapper for the friendly PokeAPI database"
+url="https://github.com/GregHilmes/pokebase"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3 py3-requests py3-certifi py3-chardet py3-idna py3-urllib3"
+makedepends="py3-setuptools"
+source="https://pypi.python.org/packages/source/p/pokebase/pokebase-$pkgver.tar.gz"
+options="!check" # No tests in pypi package
+builddir="$srcdir/pokebase-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b6f3e89cb5b95cf6703755526e69ce27e294ef1b7095267e2fd419d0fecd0e7168239319f83d301b2e30f811346275d0cdb7c0a40cf368c90ff31fa503f95ab8 pokebase-1.2.0.tar.gz"