aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/libfreehand/APKBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/community/libfreehand/APKBUILD b/community/libfreehand/APKBUILD
index 9842331767c..871a3b745cf 100644
--- a/community/libfreehand/APKBUILD
+++ b/community/libfreehand/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=libfreehand
pkgver=0.1.2
-pkgrel=0
+pkgrel=1
pkgdesc="Import filter and tools for Adobe FreeHand documents"
url="https://wiki.documentfoundation.org/DLP/Libraries/libfreehand"
arch="all"
@@ -13,7 +13,8 @@ makedepends="$depends_dev gperf perl doxygen librevenge-dev zlib-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="http://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+
+builddir="$srcdir/$pkgname-$pkgver"
prepare() {
default_prepare
@@ -33,6 +34,11 @@ build() {
make
}
+check() {
+ cd "$builddir"
+ make check
+}
+
package() {
cd "$builddir"
make DESTDIR="$pkgdir" install