aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/anytun/APKBUILD2
-rw-r--r--community/anytun/boost-1740.patch61
2 files changed, 63 insertions, 0 deletions
diff --git a/community/anytun/APKBUILD b/community/anytun/APKBUILD
index dbc316dab64..b6c765eba1c 100644
--- a/community/anytun/APKBUILD
+++ b/community/anytun/APKBUILD
@@ -13,6 +13,7 @@ makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
source="http://www.anytun.org/download/anytun-$pkgver.tar.gz
fix-iostream.patch
+ boost-1740.patch
$pkgname.initd"
builddir="$srcdir"/$pkgname-$pkgver/src
@@ -35,4 +36,5 @@ package() {
sha512sums="c1631983c0f1d735792ae1775aedb87241ae94ccd9cda12885790ecb09e0279518d3414c41945f385b2b30ad20db6a4c68fc526d7d6f777f2929c0d23174f699 anytun-0.3.8.tar.gz
8c2eece0357666867f8cd9c7ef9307bcf88b9172ac033c18bd33ba470b3c19ad722c7eeafcda3a9ae95539d86ab04285fe5d7fa9766630f689c58e2c3fb239c3 fix-iostream.patch
+8fa427facf23cd87faed1d531b6b22a74cac41c1a8aae247748d737d1ee92b70d31d38b3bc1c9976c325df26c769ad3cfb2651ff1ec52fc9cb19962d31975945 boost-1740.patch
8ca2691139ed42474fa9d2e81e8c43ae6ec48c61d07055e6436cddb6d43521a735e315ce1e99d7ef253e8d15515416df92db51fd77e7e13f6c58c820fb9d0ffb anytun.initd"
diff --git a/community/anytun/boost-1740.patch b/community/anytun/boost-1740.patch
new file mode 100644
index 00000000000..9e5172d4405
--- /dev/null
+++ b/community/anytun/boost-1740.patch
@@ -0,0 +1,61 @@
+Description: Fix FTBFS against boost1.74
+Author: Anton Gladky <gladk@debian.org>
+Bug-Debian: https://bugs.debian.org/977219
+Last-Update: 2020-12-14
+
+Index: anytun-0.3.7/src/syncTcpConnection.cpp
+===================================================================
+--- src/syncTcpConnection.cpp
++++ src/syncTcpConnection.cpp
+@@ -67,7 +67,12 @@ void SyncTcpConnection::Send(std::string
+ boost::asio::placeholders::bytes_transferred));
+ }
+
+-#if BOOST_VERSION >= 107000
++#if BOOST_VERSION >= 107300
++SyncTcpConnection::SyncTcpConnection(const boost::asio::basic_socket_acceptor<boost::asio::ip::tcp>::executor_type& executor)
++ : socket_(executor)
++{
++}
++#elif BOOST_VERSION >= 107000
+ SyncTcpConnection::SyncTcpConnection(const boost::asio::executor& executor)
+ : socket_(executor)
+ {
+Index: anytun-0.3.7/src/syncTcpConnection.h
+===================================================================
+--- src/syncTcpConnection.h
++++ src/syncTcpConnection.h
+@@ -46,6 +46,9 @@
+ #ifndef ANYTUN_syncTcpConnection_h_INCLUDED
+ #define ANYTUN_syncTcpConnection_h_INCLUDED
+
++#define BOOST_ASIO_NO_TS_EXECUTORS
++
++
+ #include <boost/shared_ptr.hpp>
+ #include <boost/enable_shared_from_this.hpp>
+ #include <boost/function.hpp>
+@@ -60,7 +63,11 @@ public:
+ typedef boost::shared_ptr<SyncTcpConnection> pointer;
+ typedef boost::asio::ip::tcp proto;
+
+-#if BOOST_VERSION >= 107000
++#if BOOST_VERSION >= 107300
++ static pointer create(const boost::asio::basic_socket_acceptor<boost::asio::ip::tcp>::executor_type& executor) {
++ return pointer(new SyncTcpConnection(executor));
++ };
++#elif BOOST_VERSION >= 107000
+ static pointer create(const boost::asio::executor& executor) {
+ return pointer(new SyncTcpConnection(executor));
+ };
+@@ -76,7 +83,9 @@ public:
+ void start();
+ void Send(std::string message);
+ private:
+-#if BOOST_VERSION >= 107000
++#if BOOST_VERSION >= 107300
++ SyncTcpConnection(const boost::asio::basic_socket_acceptor<boost::asio::ip::tcp>::executor_type& executor);
++#elif BOOST_VERSION >= 107000
+ SyncTcpConnection(const boost::asio::executor& executor);
+ #else
+ SyncTcpConnection(boost::asio::io_service& io_service);