aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ceph/APKBUILD18
-rw-r--r--community/ceph/ceph-mgr-node.post-deinstall4
-rw-r--r--community/ceph/ceph-mgr-node.post-install5
3 files changed, 25 insertions, 2 deletions
diff --git a/community/ceph/APKBUILD b/community/ceph/APKBUILD
index ad2f9b87631..80fc52f6c85 100644
--- a/community/ceph/APKBUILD
+++ b/community/ceph/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: John Coyle <dx9err@gmail.com>
# Maintainer: Iggy Jackson <iggy@kws1.com>
pkgname=ceph
-pkgver=14.2.19
+pkgver=14.2.20
pkgrel=0
pkgdesc="Ceph is a distributed object store and file system"
pkgusers="ceph"
@@ -100,6 +100,7 @@ subpackages="
$pkgname-common
$pkgname-mds
$pkgname-mgr
+ $pkgname-mgr-node:mgr_node:noarch
$pkgname-mon::noarch
$pkgname-mon-daemon:mon_daemon
$pkgname-mon-tools:mon_tools
@@ -126,6 +127,8 @@ subpackages="
"
# secfixes:
+# 14.2.20-r0:
+# - CVE-2021-20288
# 14.2.19-r0:
# - CVE-2020-27781
# - CVE-2020-25660
@@ -522,6 +525,17 @@ mgr() {
"$subpkgdir"$_localstatedir/lib/ceph/mgr
}
+mgr_node() {
+ pkgdesc="Ceph Manager NodeJS installed modules"
+ depends="$pkgname-mgr=$pkgver-r$pkgrel nodejs npm"
+ install="$subpkgname.post-install $subpkgname.post-deinstall"
+
+ mkdir -p "$subpkgdir"/usr/share/ceph/mgr/dashboard/frontend
+ cd "$subpkgdir"/usr/share/ceph/mgr/dashboard/frontend
+ cp "$builddir"/src/pybind/mgr/dashboard/frontend/package*.json ./
+ npm shrinkwrap
+}
+
_pkg() {
local path=$1
shift
@@ -535,7 +549,7 @@ _pkg() {
done
}
-sha512sums="69e3adba292d003e364f3b7eb16878992a3f3015a1ad0b73a9bd9b4ccb2f2f46518833346d40e024b62274985d30b684e1927e533a34a1e357a1780812c231fa ceph_14.2.19.orig.tar.gz
+sha512sums="e67baabaf611dc9a52fb0114a491f72666f87ec7dd4dbd63448581baebaa9cd1e70a4e90b2f2db06bf675b778858d1b057aa39986ac858de7f3894b24b07bf7e ceph_14.2.20.orig.tar.gz
e1becd813ed3f28e2e4a6bef78b3b5117c1c0bb9cabe0ba9c912e0a20b551b6b2667495cddb94acd64192e287144911ff1c11e0d636fe04cc458146cfb0daca8 allperms.patch
35722b11ad52a3145153635b6a96abda2a23ae9c7e63e2eac006c1e5b8014452c4a1a11bbe0292fd731e4c43aa38e27dd75d2ff9d25bcf52290278f71e868570 musl-fixes.patch
668a852858ed8b4743c30d6a687d3c90ab10d6b96ed7fbc04fbf8d86742d33b2dcf2b6862e0989e633f3e714c00a63fb514eb6a146211e75b4d0d36d5656e1c1 fix-seek-data-hole.patch
diff --git a/community/ceph/ceph-mgr-node.post-deinstall b/community/ceph/ceph-mgr-node.post-deinstall
new file mode 100644
index 00000000000..17955c8c04c
--- /dev/null
+++ b/community/ceph/ceph-mgr-node.post-deinstall
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+rm -rf /usr/share/ceph/mgr/dashboard/frontend/node_modules
+exit 0
diff --git a/community/ceph/ceph-mgr-node.post-install b/community/ceph/ceph-mgr-node.post-install
new file mode 100644
index 00000000000..e3de2749e19
--- /dev/null
+++ b/community/ceph/ceph-mgr-node.post-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+cd /usr/share/ceph/mgr/dashboard/frontend
+NG_CLI_ANALYTICS=false npm ci --userconfig "$(pwd)"/.npmrc --only=prod
+exit 0