aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/gnuradio/APKBUILD7
-rw-r--r--testing/gnuradio/boost.patch58
2 files changed, 63 insertions, 2 deletions
diff --git a/testing/gnuradio/APKBUILD b/testing/gnuradio/APKBUILD
index 45b54e78790..61123822f85 100644
--- a/testing/gnuradio/APKBUILD
+++ b/testing/gnuradio/APKBUILD
@@ -40,7 +40,9 @@ depends="
py3-yaml
"
subpackages="$pkgname-doc $pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/gnuradio/gnuradio/releases/download/v$pkgver/gnuradio-$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/gnuradio/gnuradio/releases/download/v$pkgver/gnuradio-$pkgver.tar.gz
+ boost.patch
+ "
build() {
cmake -B build \
@@ -79,4 +81,5 @@ check() {
xvfb-run cmake --build build --target test
}
-sha512sums="28ac794f3016ebf598467fda2ca90500f6479b773bb7d3c1c7e21fc1fdcac83f9e1973ef5ad9132f17333f786cf0f4a1d17c2b9256e4fa216c8e5bb7550d2474 gnuradio-3.8.2.0.tar.gz"
+sha512sums="28ac794f3016ebf598467fda2ca90500f6479b773bb7d3c1c7e21fc1fdcac83f9e1973ef5ad9132f17333f786cf0f4a1d17c2b9256e4fa216c8e5bb7550d2474 gnuradio-3.8.2.0.tar.gz
+9ea85fc17ae2910c268955097b9e36bd530fce1092451231df6b124f39440b2d03739d98132403d1dccf942346f0cf4a286988d10709d0c64e1fa225daf80a97 boost.patch"
diff --git a/testing/gnuradio/boost.patch b/testing/gnuradio/boost.patch
new file mode 100644
index 00000000000..bee81049e24
--- /dev/null
+++ b/testing/gnuradio/boost.patch
@@ -0,0 +1,58 @@
+From cbcb968358fad56f3646619b258f18b0e6693a07 Mon Sep 17 00:00:00 2001
+From: Jeff Long <willcode4@gmail.com>
+Date: Wed, 25 Nov 2020 09:44:55 -0500
+Subject: [PATCH 1/2] Boost placeholder scope required (using
+ boost::placeholders)
+
+---
+ gnuradio-runtime/include/gnuradio/basic_block.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/gnuradio-runtime/include/gnuradio/basic_block.h b/gnuradio-runtime/include/gnuradio/basic_block.h
+index 1d31e2e9b8..0aace8f38d 100644
+--- a/gnuradio-runtime/include/gnuradio/basic_block.h
++++ b/gnuradio-runtime/include/gnuradio/basic_block.h
+@@ -41,7 +41,7 @@
+ #include <gnuradio/rpcregisterhelpers.h>
+
+ namespace gr {
+-
++using namespace boost::placeholders;
+ /*!
+ * \brief The abstract base class for all signal processing blocks.
+ * \ingroup internal
+
+From 951b16756934f28bc3da4b3c442651b2fbe79b05 Mon Sep 17 00:00:00 2001
+From: Jeff Long <willcode4@gmail.com>
+Date: Wed, 25 Nov 2020 11:05:56 -0500
+Subject: [PATCH 2/2] boost bind: make placeholder namespace conditional on
+ boost version
+
+---
+ gnuradio-runtime/include/gnuradio/basic_block.h | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/gnuradio-runtime/include/gnuradio/basic_block.h b/gnuradio-runtime/include/gnuradio/basic_block.h
+index 0aace8f38d..c57c1cf553 100644
+--- a/gnuradio-runtime/include/gnuradio/basic_block.h
++++ b/gnuradio-runtime/include/gnuradio/basic_block.h
+@@ -33,6 +33,9 @@
+ #include <boost/foreach.hpp>
+ #include <boost/function.hpp>
+ #include <boost/thread/condition_variable.hpp>
++#if (BOOST_VERSION >= 106000)
++#include <boost/bind/bind.hpp>
++#endif
+ #include <deque>
+ #include <iostream>
+ #include <map>
+@@ -41,7 +44,9 @@
+ #include <gnuradio/rpcregisterhelpers.h>
+
+ namespace gr {
++#if (BOOST_VERSION >= 106000)
+ using namespace boost::placeholders;
++#endif
+ /*!
+ * \brief The abstract base class for all signal processing blocks.
+ * \ingroup internal