aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/alpine-conf/0001-update-kernel-include-associated-firmware-files-to-m.patch34
-rw-r--r--main/alpine-conf/APKBUILD6
2 files changed, 38 insertions, 2 deletions
diff --git a/main/alpine-conf/0001-update-kernel-include-associated-firmware-files-to-m.patch b/main/alpine-conf/0001-update-kernel-include-associated-firmware-files-to-m.patch
new file mode 100644
index 00000000000..7c90ca4f22d
--- /dev/null
+++ b/main/alpine-conf/0001-update-kernel-include-associated-firmware-files-to-m.patch
@@ -0,0 +1,34 @@
+From f7c6df674f7c5556c4a58d03310eb84e1d4f4676 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 22 Mar 2019 19:55:07 +0200
+Subject: [PATCH] update-kernel: include associated firmware files to modloop
+
+Some drivers reference only the .bin but require additional
+files such as .$board.txt or .clm_blob. Include all files
+in modloop that might match. ref #9549
+---
+ update-kernel.in | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/update-kernel.in b/update-kernel.in
+index eeb0716..0079182 100644
+--- a/update-kernel.in
++++ b/update-kernel.in
+@@ -278,10 +278,10 @@ mkdir -p $MODLOOP/modules/firmware
+ find $ROOT/lib/modules -type f -name "*.ko" | xargs modinfo -F firmware | sort -u | while read FW; do
+ if [ -e "$ROOT/lib/firmware/$FW" ]; then
+ install -pD $ROOT/lib/firmware/$FW $MODLOOP/modules/firmware/$FW
+- # include nvram files if firmware is needed.
+- if [ -e "$ROOT/lib/firmware/${FW%.*}.txt" ]; then
+- install -pD $ROOT/lib/firmware/${FW%.*}.txt $MODLOOP/modules/firmware/${FW%.*}.txt
+- fi
++ # copy also all potentially associated files
++ for _file in "$ROOT"/lib/firmware/"${FW%.*}".*; do
++ install -pD "$_file" "$MODLOOP/modules/firmware/${_file#*/lib/firmware/}"
++ done
+ fi
+ done
+
+--
+2.21.0
+
diff --git a/main/alpine-conf/APKBUILD b/main/alpine-conf/APKBUILD
index bcd29be24ca..e705a01210c 100644
--- a/main/alpine-conf/APKBUILD
+++ b/main/alpine-conf/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=alpine-conf
pkgver=3.8.1
-pkgrel=3
+pkgrel=4
pkgdesc="Alpine configuration management scripts"
url=http://git.alpinelinux.org/cgit/$pkgname
arch="all"
@@ -11,6 +11,7 @@ source="https://dev.alpinelinux.org/archive/alpine-conf/alpine-conf-$pkgver.tar.
0001-setup-alpine-setup-ntp-before-repos.patch
0001-update-kernel-include-regulatory-database.patch
0001-update-kernel-add-modloopfw-option.patch
+ 0001-update-kernel-include-associated-firmware-files-to-m.patch
"
builddir="$srcdir"/$pkgname-$pkgver
@@ -30,4 +31,5 @@ package() {
sha512sums="6aa0f0eaab6ee1ff8f9259d5c4e4634bf6d736a2cb52efb3cbabfdfcdd5dcd81b9fe05073ac16f964e7b74b5006b5f4219b33ab4ff5f984273b3bb48982afd6a alpine-conf-3.8.1.tar.xz
4b1b88b66a0771720e1991534c0d55b17293d0d9c3e4064d4210c2edd2fcbe8f6691bf5336b5492312df6160aad8f17b4bb4f9174efd4bad342472b3ad2a16bc 0001-setup-alpine-setup-ntp-before-repos.patch
544498b30bd57c84521a4fd5fbd45791b9307dcd29532278f45b61fb14d6405b5454e98fb535fd31331793b806ef897e208c3c6f8bc772dbd55ae2c61abcb402 0001-update-kernel-include-regulatory-database.patch
-65f6f79a841ab661ab5fdd41c5e78f4bb74bbc4b1d252291d64cb9d5afa6853133d562c2069bf138b39407c8a0ecc37697b5d17534ded7b8dab8490be6a13698 0001-update-kernel-add-modloopfw-option.patch"
+65f6f79a841ab661ab5fdd41c5e78f4bb74bbc4b1d252291d64cb9d5afa6853133d562c2069bf138b39407c8a0ecc37697b5d17534ded7b8dab8490be6a13698 0001-update-kernel-add-modloopfw-option.patch
+bfdaa44b0e02fb49c74ff8a6f3292356a6856a1a8aac005d14fe396f02a1c881658c1d9cfe69216fdf0f7c0cfad547cff57270bb8ab87390f0e1e9addfb68fe9 0001-update-kernel-include-associated-firmware-files-to-m.patch"