aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/cracklib/APKBUILD45
1 files changed, 19 insertions, 26 deletions
diff --git a/main/cracklib/APKBUILD b/main/cracklib/APKBUILD
index f4b5084a8b8..f677e4c2e60 100644
--- a/main/cracklib/APKBUILD
+++ b/main/cracklib/APKBUILD
@@ -1,30 +1,22 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=cracklib
-pkgver=2.9.6
+pkgver=2.9.7
pkgrel=0
pkgdesc="A library used to enforce strong passwords"
-url="https://sourceforge.net/projects/cracklib"
+url="https://github.com/cracklib/cracklib"
arch="all"
license="LGPL-2.0-or-later"
-depends=""
-makedepends=""
-install=
subpackages="$pkgname-dev"
-source="https://github.com/cracklib/cracklib/releases/download/$pkgname-$pkgver/$pkgname-$pkgver.tar.gz"
+source="https://github.com/cracklib/cracklib/releases/download/v$pkgver/cracklib-$pkgver.tar.bz2"
+builddir="$srcdir"/$pkgname-$pkgver
+
+# secfixes:
+# 2.9.7-r0:
+# - CVE-2016-6318
-_builddir="$srcdir"/$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -34,17 +26,18 @@ build() {
--infodir=/usr/share/info \
--without-python \
--disable-nls \
- --with-default-dict \
- || return 1
- make -j1 all || return 1
+ --with-default-dict
+ make -j1 all
}
-package() {
- cd "$_builddir"
- make -j1 DESTDIR="$pkgdir" install || return 1
+check() {
+ cd "$builddir"
+ make check
+}
+package() {
+ cd "$builddir"
+ make -j1 DESTDIR="$pkgdir" install
}
-md5sums="c52f463585d85924b28cdc1e373ae06d cracklib-2.9.6.tar.gz"
-sha256sums="17cf76943de272fd579ed831a1fd85339b393f8d00bf9e0d17c91e972f583343 cracklib-2.9.6.tar.gz"
-sha512sums="2b09672e5b412d670e7ed911ebf0c0023fe2901ea05c9c02eefb7a58a13cddbc27a65d75bb20be9f8cebf4c90a9a56dfe1a3b656dff62b1d6048f5376e671786 cracklib-2.9.6.tar.gz"
+sha512sums="f6bf65ac092ba46ff78ddbc115692260fb76dc71219cd679d2ea935ebfb9e709fbb30259a7406743ed00dbdc415335b3ac9d9fcba1d204ea36d5eb96bf1333a2 cracklib-2.9.7.tar.bz2"