aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/py3-httpretty/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/testing/py3-httpretty/APKBUILD b/testing/py3-httpretty/APKBUILD
index f0fd5f3bcd8..32e56df2b77 100644
--- a/testing/py3-httpretty/APKBUILD
+++ b/testing/py3-httpretty/APKBUILD
@@ -1,20 +1,18 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py3-httpretty
-_pyname=httpretty
-pkgver=0.9.7
-pkgrel=1
+pkgver=1.0.2
+pkgrel=0
pkgdesc="HTTP client mocking tool for Python"
url="https://github.com/gabrielfalcao/HTTPretty"
arch="noarch"
license="MIT"
depends="python3"
makedepends="python3-dev py3-setuptools"
-_pypiprefix="${_pyname%${_pyname#?}}"
-source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/h/httpretty/httpretty-$pkgver.tar.gz"
replaces="py-httpretty"
provides="py-httpretty=$pkgver-r$pkgrel"
-builddir="$srcdir"/$_pyname-$pkgver
+builddir="$srcdir"/httpretty-$pkgver
build() {
python3 setup.py build
@@ -30,4 +28,4 @@ package() {
chmod 644 "$pkgdir"/usr/lib/python3*/site-packages/*.egg-info/*
}
-sha512sums="4a1cdfc09af14ab2bc6eec84ad0905103ffb48c3154b127f646b39ff131584a52b1fd56bfe7a41959fc68d64eff94a221f9bf5a159a3dbfb3535fe4ac76c6170 httpretty-0.9.7.tar.gz"
+sha512sums="f9ef1c82f4fe3a31696e06228cea512664c5118b3c32910d7810d1fcf16b05d31b9b55db7bb6bd64967aadb162a2952757627439769db9117164b8248de9049c httpretty-1.0.2.tar.gz"