aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ffmpeg/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/community/ffmpeg/APKBUILD b/community/ffmpeg/APKBUILD
index 504072be81a..8c79bee8c72 100644
--- a/community/ffmpeg/APKBUILD
+++ b/community/ffmpeg/APKBUILD
@@ -135,6 +135,12 @@ source="https://ffmpeg.org/releases/ffmpeg-$pkgver.tar.xz
# - CVE-2017-14223
# - CVE-2017-14225
+# This is a huge library of audio/video codecs; performance matters,
+# compiling it with -Os doesn't make sense.
+export CFLAGS=${CFLAGS/-Os/}
+export CPPFLAGS=${CPPFLAGS/-Os/}
+export CXXFLAGS=${CXXFLAGS/-Os/}
+
build() {
local _dbg="--disable-debug"
local _asm=""