aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/expect/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/main/expect/APKBUILD b/main/expect/APKBUILD
index 16b0975659f..990fec99d51 100644
--- a/main/expect/APKBUILD
+++ b/main/expect/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <francesco.colista@gmail.com>
pkgname=expect
pkgver=5.45
-pkgrel=3
+pkgrel=4
pkgdesc="A tool for automating interactive applications"
url="http://www.nist.gov/el/msid/expect.cfm"
arch="all"
@@ -13,14 +13,17 @@ makedepends="$depends_dev"
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/project/expect/Expect/$pkgver/$pkgname$pkgver.tar.gz"
-_builddir="$srcdir"/$pkgname$pkgver
+builddir="$srcdir"/$pkgname$pkgver
+
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ default_prepare
+
+ cd "$builddir"
+ update_config_sub
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -30,13 +33,18 @@ build() {
--mandir=/usr/share/man \
--with-tcl=/usr/lib \
--with-tclinclude=/usr/include \
- --disable-rpath \
- || return 1
- make || return 1
+ --disable-rpath
+ make
}
+
+check() {
+ cd "$builddir"
+ make test
+}
+
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="be991c68241e607b3a689eae7e7966056dbfb577e857331d54a4911bd178c1816425217603b43918ad1b6d2e966271a0f01e79d7028a22e223562d59d10c8c51 expect5.45.tar.gz"