aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/cpptest/APKBUILD11
1 files changed, 3 insertions, 8 deletions
diff --git a/community/cpptest/APKBUILD b/community/cpptest/APKBUILD
index cfbd709857e..102875a44be 100644
--- a/community/cpptest/APKBUILD
+++ b/community/cpptest/APKBUILD
@@ -1,21 +1,16 @@
# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=cpptest
-pkgver=1.1.2
+pkgver=2.0.0
pkgrel=0
pkgdesc="Portable and powerful unit testing framework for handling automated tests in C++"
url="http://cpptest.sourceforge.net/"
arch="all"
license="LGPL"
subpackages="$pkgname-dev"
-source="https://sourceforge.net/projects/cpptest/files/cpptest/cpptest-1.1.2/cpptest-1.1.2.tar.gz"
+source="https://github.com/cpptest/cpptest/releases/download/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
-prepare() {
- default_prepare
- update_config_guess
-}
-
build() {
cd "$builddir"
./configure --prefix=/usr
@@ -32,4 +27,4 @@ package() {
make install DESTDIR="$pkgdir"
}
-sha512sums="da1030c69a5886e752b9ae08b65c501334c7d2d4abd2174190209ce11ed351239a615b9f7c5019ee601289523b2c21a1205d2042e59aea6c2882d77d636fc57a cpptest-1.1.2.tar.gz"
+sha512sums="72149e785881b9f2190ff28e74f5edc1056ce1de087fcccf4debbc59818c164907b5374892c7a750552b3c9d25454da0735e3da7902f4e6ef4174bc3b635248c cpptest-2.0.0.tar.gz"