aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/libqtxdg/APKBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/testing/libqtxdg/APKBUILD b/testing/libqtxdg/APKBUILD
index 853fb3358b0..6bc560d1851 100644
--- a/testing/libqtxdg/APKBUILD
+++ b/testing/libqtxdg/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Antoni Aloy <aaloytorrens@gmail.com>
pkgname=libqtxdg
-pkgver=3.7.1
+pkgver=3.8.0
pkgrel=0
pkgdesc="Qt implementation of freedesktop.org xdg specifications"
url="https://github.com/lxqt/libqtxdg"
@@ -11,8 +11,8 @@ makedepends="
cmake lxqt-build-tools qt5-qtbase-dev
qt5-qtsvg-dev glib-dev
"
+checkdepends="xvfb-run"
subpackages="$pkgname-dev"
-options="!check" # No testsuite
source="https://github.com/lxqt/libqtxdg/releases/download/$pkgver/libqtxdg-$pkgver.tar.xz"
build() {
@@ -24,11 +24,16 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_SHARED_LIBS=True \
+ -DBUILD_TESTS=Yes \
$CMAKE_CROSSOPTS .
cmake --build build
}
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run cmake --build build --target test
+}
+
package() {
DESTDIR="$pkgdir" cmake --build build --target install
@@ -37,5 +42,5 @@ package() {
}
sha512sums="
-764fb953c5c5564a8f5e189f3fa867b82e1da215e0734d2fb995bb29ba163936a38cf68c6c812ff3c183b7ab4fce59d1189c68885b65f103accb5446e71682e7 libqtxdg-3.7.1.tar.xz
+e9e8d163fe1a60a2d03787ec3feef6ff6e89dfea4df7c0c7b3a72784992baf49ffeb352894d3cb8747ec0cd49576562f7dae3abbde932d13374f51bc77f14ea1 libqtxdg-3.8.0.tar.xz
"