aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/connman/APKBUILD6
-rw-r--r--community/connman/connman.confd4
-rw-r--r--community/connman/connman.initd6
3 files changed, 13 insertions, 3 deletions
diff --git a/community/connman/APKBUILD b/community/connman/APKBUILD
index 5ca59d67396..747b5971ad5 100644
--- a/community/connman/APKBUILD
+++ b/community/connman/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=connman
pkgver=1.40
-pkgrel=4
+pkgrel=5
pkgdesc="Daemon for managing internet connections"
url="https://git.kernel.org/pub/scm/network/connman/connman.git"
arch="all"
@@ -159,6 +159,6 @@ wireguard() {
sha512sums="
33df90814b7499aeafcd51fca4f8ffbc07efacfa29dda46d3b9bcd3ff26264dc53c3991e7e53a8563ca403015c345e59c7ad29427c38ee3d88dd282479db7a0f connman-1.40.tar.xz
122b48fc9e25354e25ba3a3e0864bdd84da84457fed94aeea726bcb189b2f05f2cc361ae15f44af5c49bcee572e91e4c0488ef3b0bc79d20f6efe15853fb6b3a libresolv.patch
-17c21c1c3e138790610a30ff397272e8f10b348c630e11f340fc7e97bdb871be00abc2955e11b9dad2c4be44cb6fdbf26c6c73aa18c1a2109f0668b14278593f connman.initd
-4d266e0cb30af7aec5359a5456b12c9358c266ce0a7afdff247da7423f91b99748a15e44facec51eaab0f5a193b9c7542d9a3988c85f1bf5027a742aea995326 connman.confd
+4bedfb21a941f6fc1f854a565dcdb1b8675888c23a112ad60645c56e7c602029089a067d0317cc156a3edf624ebbc8d0696bfb61a4b09c9becd04ee3b1d65a29 connman.initd
+73f505a777df04039ca51bc3959aa89969a0bbc21ea971fb98e04e9b5851553de35955453ed859f5a6273724bbcce38f13012950c6cb4e0a2bc80bc531ccff1e connman.confd
"
diff --git a/community/connman/connman.confd b/community/connman/connman.confd
index d46fe907fdb..c5d99390423 100644
--- a/community/connman/connman.confd
+++ b/community/connman/connman.confd
@@ -6,5 +6,9 @@
# Additional arguments to pass to connmand.
#command_args=
+# Number of milliseconds to wait after starting and check that daemon is
+# still running.
+#start_wait=50
+
# Uncomment to use process supervisor.
#supervisor="supervise-daemon"
diff --git a/community/connman/connman.initd b/community/connman/connman.initd
index 3db84280a77..be853105606 100644
--- a/community/connman/connman.initd
+++ b/community/connman/connman.initd
@@ -4,6 +4,7 @@ name="ConnMan"
description="Daemon for managing internet connections"
: ${cfgfile:=/etc/connman/main.conf}
+: ${start_wait=50} # milliseconds
command=/usr/sbin/connmand
command_args="$command_args -c $cfgfile --nodaemon"
@@ -11,6 +12,11 @@ command_background="yes"
pidfile="/run/$RC_SVCNAME.pid"
required_files="$cfgfile"
+start_stop_daemon_args="
+ ${start_wait:+--wait $start_wait}
+ ${start_stop_daemon_args:-}
+ "
+
depend() {
need dbus
provide net