aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/giara/0e6d5cab96e7b3f8db15739a3e00b9d1a3a48fb1.patch264
-rw-r--r--community/giara/6204427f8b8e3d8c72b669717a3f129ffae401d9.patch26
-rw-r--r--community/giara/APKBUILD33
-rw-r--r--community/giara/c5685fa39024f8597a83c8b0a52a0bad28d20dba.patch31
4 files changed, 344 insertions, 10 deletions
diff --git a/community/giara/0e6d5cab96e7b3f8db15739a3e00b9d1a3a48fb1.patch b/community/giara/0e6d5cab96e7b3f8db15739a3e00b9d1a3a48fb1.patch
new file mode 100644
index 00000000000..5296d82d794
--- /dev/null
+++ b/community/giara/0e6d5cab96e7b3f8db15739a3e00b9d1a3a48fb1.patch
@@ -0,0 +1,264 @@
+From 0e6d5cab96e7b3f8db15739a3e00b9d1a3a48fb1 Mon Sep 17 00:00:00 2001
+From: Gabriele Musco <gabmus@disroot.org>
+Date: Wed, 13 Oct 2021 08:24:43 +0200
+Subject: [PATCH] updated to libadwaita 1 alpha 3; related fixes
+
+---
+ data/ui/gtk_style.css | 10 +++++-----
+ data/ui/headerbar.ui | 14 ++-----------
+ data/ui/headerbar_with_back_and_squeezer.ui | 22 +--------------------
+ data/ui/post_details_headerbar.ui | 14 ++-----------
+ data/ui/subreddit_view_headerbar.ui | 21 +++-----------------
+ dist/flatpak/org.gabmus.giara.json | 17 ++++++++--------
+ giara/app_window.py | 12 +++++++----
+ giara/inbox_view.py | 2 +-
+ giara/squeezing_viewswitcher_headerbar.py | 2 +-
+ 9 files changed, 31 insertions(+), 83 deletions(-)
+
+diff --git a/data/ui/gtk_style.css b/data/ui/gtk_style.css
+index f49b2f5..c6ecf12 100644
+--- a/data/ui/gtk_style.css
++++ b/data/ui/gtk_style.css
+@@ -7,7 +7,7 @@
+ padding-left: 12px;
+ margin-top: 6px;
+ margin-bottom: 6px;
+- margin-left: 6px
++ margin-left: 6px;
+ }
+
+ .nested-0 {
+@@ -130,8 +130,8 @@
+ font-size: .6em;
+ border-radius: .6em;
+ background-color: #ed333b;
+- color: black;
+- margin-top: 3px;
++ color: black;
++ margin-top: 3px;
+ }
+
+ .collapse-icon {
+@@ -169,8 +169,8 @@
+ opacity: .8;
+ }
+
+-.gallery-picture {
+-}
++/* .gallery-picture { */
++/* } */
+
+ .picture-rounded:focus {
+ border-color: @theme_selected_bg_color;
+diff --git a/data/ui/headerbar.ui b/data/ui/headerbar.ui
+index a8f10d0..b3f1ab3 100644
+--- a/data/ui/headerbar.ui
++++ b/data/ui/headerbar.ui
+@@ -212,13 +212,8 @@
+ <object class="GtkButton" id="refresh_btn">
+ <property name="visible">True</property>
+ <property name="receives-default">True</property>
++ <property name="icon-name">view-refresh-symbolic</property>
+ <property name="tooltip-text" translatable="yes">Refresh</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon-name">view-refresh-symbolic</property>
+- </object>
+- </child>
+ </object>
+ </child>
+ <child type="end">
+@@ -236,12 +231,7 @@
+ <property name="visible">True</property>
+ <property name="receives-default">True</property>
+ <property name="tooltip-text" translatable="yes">Search</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon-name">system-search-symbolic</property>
+- </object>
+- </child>
++ <property name="icon-name">system-search-symbolic</property>
+ </object>
+ </child>
+ <child>
+diff --git a/data/ui/headerbar_with_back_and_squeezer.ui b/data/ui/headerbar_with_back_and_squeezer.ui
+index af1d167..b43f5d9 100644
+--- a/data/ui/headerbar_with_back_and_squeezer.ui
++++ b/data/ui/headerbar_with_back_and_squeezer.ui
+@@ -9,9 +9,6 @@
+ <object class="AdwSqueezer" id="squeezer">
+ <property name="visible">True</property>
+ <property name="homogeneous">True</property>
+- <child>
+- <placeholder/>
+- </child>
+ </object>
+ </child>
+ <child>
+@@ -19,25 +16,8 @@
+ <property name="visible">True</property>
+ <property name="receives_default">True</property>
+ <property name="tooltip_text" translatable="yes">Back</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon_name">go-previous-symbolic</property>
+- </object>
+- </child>
++ <property name="icon_name">go-previous-symbolic</property>
+ </object>
+ </child>
+- <child>
+- <placeholder/>
+- </child>
+- <child>
+- <placeholder/>
+- </child>
+- <child>
+- <placeholder/>
+- </child>
+- <child>
+- <placeholder/>
+- </child>
+ </object>
+ </interface>
+diff --git a/data/ui/post_details_headerbar.ui b/data/ui/post_details_headerbar.ui
+index 822c592..d840eff 100644
+--- a/data/ui/post_details_headerbar.ui
++++ b/data/ui/post_details_headerbar.ui
+@@ -9,12 +9,7 @@
+ <property name="visible">True</property>
+ <property name="receives_default">True</property>
+ <property name="tooltip_text" translatable="yes">Back</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon_name">go-previous-symbolic</property>
+- </object>
+- </child>
++ <property name="icon_name">go-previous-symbolic</property>
+ </object>
+ </child>
+ <child>
+@@ -22,12 +17,7 @@
+ <property name="visible">True</property>
+ <property name="receives_default">True</property>
+ <property name="tooltip_text" translatable="yes">Refresh</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon_name">view-refresh-symbolic</property>
+- </object>
+- </child>
++ <property name="icon_name">view-refresh-symbolic</property>
+ </object>
+ </child>
+ </object>
+diff --git a/data/ui/subreddit_view_headerbar.ui b/data/ui/subreddit_view_headerbar.ui
+index bf6ee17..a1a52c0 100644
+--- a/data/ui/subreddit_view_headerbar.ui
++++ b/data/ui/subreddit_view_headerbar.ui
+@@ -18,12 +18,7 @@
+ <property name="visible">True</property>
+ <property name="receives-default">True</property>
+ <property name="tooltip-text" translatable="yes">Back</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon-name">go-previous-symbolic</property>
+- </object>
+- </child>
++ <property name="icon-name">go-previous-symbolic</property>
+ </object>
+ </child>
+ <child>
+@@ -31,12 +26,7 @@
+ <property name="visible">True</property>
+ <property name="receives-default">True</property>
+ <property name="tooltip-text" translatable="yes">Refresh</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon-name">view-refresh-symbolic</property>
+- </object>
+- </child>
++ <property name="icon-name">view-refresh-symbolic</property>
+ </object>
+ </child>
+ <child>
+@@ -50,12 +40,7 @@
+ <property name="visible">True</property>
+ <property name="receives-default">True</property>
+ <property name="tooltip-text" translatable="yes">Search</property>
+- <child>
+- <object class="GtkImage">
+- <property name="visible">True</property>
+- <property name="icon-name">system-search-symbolic</property>
+- </object>
+- </child>
++ <property name="icon-name">system-search-symbolic</property>
+ </object>
+ </child>
+ </object>
+diff --git a/giara/app_window.py b/giara/app_window.py
+index a0e3976..1070199 100644
+--- a/giara/app_window.py
++++ b/giara/app_window.py
+@@ -19,7 +19,7 @@ class AppWindow(Adw.ApplicationWindow):
+ self.main_ui = MainUI()
+ self.main_box.append(self.main_ui)
+
+- self.set_child(self.main_box)
++ self.set_content(self.main_box)
+
+ def toggle_popover(*args):
+ self.main_ui.deck.left_stack.get_headerbar().menu_btn.popup()
+@@ -50,10 +50,14 @@ class AppWindow(Adw.ApplicationWindow):
+ self.on_dark_mode_changed()
+
+ def on_dark_mode_changed(self, *args):
+- Gtk.Settings.get_default().set_property(
+- 'gtk-application-prefer-dark-theme',
+- self.confman.conf['dark_mode']
++ Adw.StyleManager.get_default().set_color_scheme(
++ Adw.ColorScheme.FORCE_DARK if self.confman.conf['dark_mode']
++ else Adw.ColorScheme.DEFAULT
+ )
++ # Gtk.Settings.get_default().set_property(
++ # 'gtk-application-prefer-dark-theme',
++ # self.confman.conf['dark_mode']
++ # )
+
+ def emit_destroy(self, *args):
+ self.emit('destroy')
+diff --git a/giara/inbox_view.py b/giara/inbox_view.py
+index cbba98d..5139cb7 100644
+--- a/giara/inbox_view.py
++++ b/giara/inbox_view.py
+@@ -31,7 +31,7 @@ class InboxItemView(Gtk.Box):
+ self.avatar_container = self.builder.get_object('avatar_container')
+ self.avatar = SimpleAvatar(
+ 42,
+- self.item.author.name,
++ self.item.author.name if self.item.author else _('Author unknown'),
+ self.get_author_img
+ )
+ self.avatar_container.append(self.avatar)
+diff --git a/giara/squeezing_viewswitcher_headerbar.py b/giara/squeezing_viewswitcher_headerbar.py
+index 2829e21..5fc58f4 100644
+--- a/giara/squeezing_viewswitcher_headerbar.py
++++ b/giara/squeezing_viewswitcher_headerbar.py
+@@ -31,7 +31,7 @@ class SqueezingViewSwitcherHeaderbar(Gtk.WindowHandle):
+ if view_switcher and stack is not None:
+ self.squeezer = self.builder.get_object('squeezer')
+ self.view_switcher = Adw.ViewSwitcher()
+- self.view_switcher.set_policy(Adw.ViewSwitcherPolicy.AUTO)
++ # self.view_switcher.set_policy(Adw.ViewSwitcherPolicy.AUTO)
+ self.squeezer.add(self.view_switcher)
+ self.squeezer.add(Gtk.Label())
+ self.squeezer.connect(
+--
+GitLab
+
diff --git a/community/giara/6204427f8b8e3d8c72b669717a3f129ffae401d9.patch b/community/giara/6204427f8b8e3d8c72b669717a3f129ffae401d9.patch
new file mode 100644
index 00000000000..a2a422a7c2c
--- /dev/null
+++ b/community/giara/6204427f8b8e3d8c72b669717a3f129ffae401d9.patch
@@ -0,0 +1,26 @@
+From 6204427f8b8e3d8c72b669717a3f129ffae401d9 Mon Sep 17 00:00:00 2001
+From: Gabriele Musco <gabmus@disroot.org>
+Date: Tue, 31 Aug 2021 09:07:14 +0200
+Subject: [PATCH] updated gtk4 and libadwaita dependencies
+
+---
+ meson.build | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 1eb2a91..62efb39 100644
+--- a/meson.build
++++ b/meson.build
+@@ -75,7 +75,8 @@ if not py_installation.found()
+ endif
+ dependency('glib-2.0')
+ dependency('gobject-introspection-1.0', version: '>=1.35.9')
+-dependency('gtk+-3.0', version :'>=3.24')
++dependency('gtk4', version :'>=4.4.0')
++dependency('libadwaita-1', version :'>=1.0.0')
+
+ gnome = import('gnome')
+ prefix = get_option('prefix') # should be /usr
+--
+GitLab
+
diff --git a/community/giara/APKBUILD b/community/giara/APKBUILD
index 00a07435ff8..373c4ac92be 100644
--- a/community/giara/APKBUILD
+++ b/community/giara/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Newbyte <newbie13xd@gmail.com>
# Maintainer: Newbyte <newbie13xd@gmail.com>
pkgname=giara
-pkgver=0.3
-pkgrel=1
+pkgver=1.0
+pkgrel=0
pkgdesc="reddit app for GNOME, created with mobile Linux in mind."
url="https://gitlab.gnome.org/World/giara"
-# mips64 and riscv64 blocked by webkit2gtk
-# s390x blocked by libhandy1
+# mips64, riscv64 blocked by webkit2gtk
+# mips64, riscv64, s390x blocked by libadwaita
arch="noarch !s390x !mips64 !riscv64"
license="GPL-3.0-or-later"
+subpackages="$pkgname-lang"
depends="
py3-beautifulsoup4
py3-cairo
@@ -18,18 +19,25 @@ depends="
py3-pillow
py3-praw
py3-requests
- gtksourceview4
- gtk+3.0
- libhandy1
+ gtksourceview5
+ gtk4.0
+ libadwaita
python3
webkit2gtk
"
makedepends="
+ appstream
gobject-introspection-dev
- gtk+3.0-dev
+ gtk4.0-dev
+ libadwaita-dev
meson
"
-source="https://gitlab.gnome.org/World/giara/-/archive/$pkgver/giara-$pkgver.tar.gz"
+options="!check"
+source="https://gitlab.gnome.org/World/giara/-/archive/$pkgver/giara-$pkgver.tar.gz
+ 6204427f8b8e3d8c72b669717a3f129ffae401d9.patch
+ c5685fa39024f8597a83c8b0a52a0bad28d20dba.patch
+ 0e6d5cab96e7b3f8db15739a3e00b9d1a3a48fb1.patch
+ "
build() {
abuild-meson . output
@@ -40,4 +48,9 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="b245379a3975647ab0469abe404527976a65a856241bc268eb4edb33ad049d98e5f6de7df03a8e16ed8f67fcb2849498072a13e217837cb78dc6feda1f63582e giara-0.3.tar.gz"
+sha512sums="
+b2349beaf809cea9b52232c998185944ca685d094291d5694f4b201a7ca52bc846521825e3a7b50a4e967644926a1e6c997e239b6dfb80083bc493b18a5c0bdc giara-1.0.tar.gz
+800c1efb66d326bbacfdfe597d9d45dc432567bd128403084df0181681f771666e1b2ae26fcf5b732d0b35a663d74ed9b2ab0fafba118f1cc583babcb8cd9195 6204427f8b8e3d8c72b669717a3f129ffae401d9.patch
+cfaf7c7b521bbf4440471a7bfc205c4b313d07a3e6cd4db5cc8e83d09f1f5d149087dc7391de90162383e854b28354215e4b03b01192f06249903d4c74b8c723 c5685fa39024f8597a83c8b0a52a0bad28d20dba.patch
+bdf9b7ec5af6f5cf0b27e59260312fe929a4aa1a05cb10091e2b1cdd509f2bb7a8ce4b5bdb37a8f90fbe6477d2fc68127ad51af75515aa39ba28b62e63053a40 0e6d5cab96e7b3f8db15739a3e00b9d1a3a48fb1.patch
+"
diff --git a/community/giara/c5685fa39024f8597a83c8b0a52a0bad28d20dba.patch b/community/giara/c5685fa39024f8597a83c8b0a52a0bad28d20dba.patch
new file mode 100644
index 00000000000..cb7ea3366ae
--- /dev/null
+++ b/community/giara/c5685fa39024f8597a83c8b0a52a0bad28d20dba.patch
@@ -0,0 +1,31 @@
+From c5685fa39024f8597a83c8b0a52a0bad28d20dba Mon Sep 17 00:00:00 2001
+From: Gabriele Musco <gabmus@disroot.org>
+Date: Sat, 4 Sep 2021 16:34:15 +0200
+Subject: [PATCH] tweaked markdown quote style
+
+---
+ data/ui/gtk_style.css | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/data/ui/gtk_style.css b/data/ui/gtk_style.css
+index f3235e8..f49b2f5 100644
+--- a/data/ui/gtk_style.css
++++ b/data/ui/gtk_style.css
+@@ -1,6 +1,13 @@
+ .nested, .nested-0, .nested-1, .nested-2, .nested-3, .nested-4, .nested-5, .nested-6, .nested-7, .nested-8, .nested-9, .markdown-quote {
+ border-left: 2px solid @theme_fg_color;
+- padding-left: 4px;
++ padding-left: 6px;
++}
++
++.markdown-quote {
++ padding-left: 12px;
++ margin-top: 6px;
++ margin-bottom: 6px;
++ margin-left: 6px
+ }
+
+ .nested-0 {
+--
+GitLab
+