aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/nlohmann-json/APKBUILD5
1 files changed, 0 insertions, 5 deletions
diff --git a/testing/nlohmann-json/APKBUILD b/testing/nlohmann-json/APKBUILD
index e7b1c721dcc..01733cd9f69 100644
--- a/testing/nlohmann-json/APKBUILD
+++ b/testing/nlohmann-json/APKBUILD
@@ -7,25 +7,20 @@ pkgdesc="JSON for Modern C++"
url="https://github.com/nlohmann/json"
arch="noarch"
license="MIT"
-depends=""
makedepends="doxygen"
-install=""
subpackages="nlohmann-json-doc"
source="nlohmann-json-$pkgver.tar.gz::https://github.com/nlohmann/json/archive/v$pkgver.tar.gz"
builddir="$srcdir/json-$pkgver"
build() {
- cd "$builddir"
make -C doc
}
check() {
- cd "$builddir"
if [ "$CARCH" != "s390x" ]; then make check-fast; fi
}
package() {
- cd "$builddir"
mkdir -p "$pkgdir/usr/include"
mv include/nlohmann "$pkgdir/usr/include"
}