aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libfastjson/APKBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/main/libfastjson/APKBUILD b/main/libfastjson/APKBUILD
index b43e7411570..9bbd2d786b8 100644
--- a/main/libfastjson/APKBUILD
+++ b/main/libfastjson/APKBUILD
@@ -2,25 +2,29 @@
# Maintainer: Ashley Sommer <ashleysommer@gmail.com>
pkgname=libfastjson
pkgver=0.99.8
-pkgrel=1
+pkgrel=2
pkgdesc="A fork of the json-c library for rsyslog, optimized for liblognorm processing."
-url="http://www.rsyslog.com/"
+url="https://www.rsyslog.com/"
arch="all"
license="MIT"
makedepends="autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-dbg"
source="$pkgname-$pkgver.tar.gz::https://github.com/rsyslog/$pkgname/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+prepare() {
+ cd "$builddir"
+ ./autogen.sh
+}
build() {
- cd "$builddir"
- sh autogen.sh \
+ cd "$builddir"
+ ./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--sysconfdir=/etc \
- --mandir=/usr/share/man
+ --mandir=/usr/share/man \
+ --disable-static
make
}