aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/lolcat/APKBUILD24
-rw-r--r--testing/lolcat/fix-url-and-version.patch24
2 files changed, 48 insertions, 0 deletions
diff --git a/testing/lolcat/APKBUILD b/testing/lolcat/APKBUILD
new file mode 100644
index 00000000000..daa1fb5fe38
--- /dev/null
+++ b/testing/lolcat/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Daniel Isaksen <d@duniel.no>
+# Maintainer: Simon Frankenberger <simon-alpine@fraho.eu>
+pkgname=lolcat
+pkgver=1.0
+pkgrel=0
+pkgdesc="High-performance implementation of lolcat"
+url="https://github.com/jaseg/lolcat/"
+arch="all"
+license="WTFPL"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jaseg/${pkgname}/archive/v$pkgver.tar.gz
+ fix-url-and-version.patch"
+options="!check" # No upstream testsuite
+
+build() {
+ make
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin"
+ make DESTDIR="$pkgdir/usr/bin" install
+}
+
+sha512sums="5f668706c2415273140047040a9e6d02d80a1572a834503480688f46466e2750f3cf5372f364039921f6461f2dbec7fa2dbe8a5600abdf3390c2caf56d1595bf lolcat-1.0.tar.gz
+14cdd61496bc0a0fbec39a8dcfb2d16d9424abfb1c6348750cb263fbb6a416bf89c6f05e549e1205fe64128c65946dcdde2a889c162336795e838b539c9b1470 fix-url-and-version.patch"
diff --git a/testing/lolcat/fix-url-and-version.patch b/testing/lolcat/fix-url-and-version.patch
new file mode 100644
index 00000000000..1005925de97
--- /dev/null
+++ b/testing/lolcat/fix-url-and-version.patch
@@ -0,0 +1,24 @@
+--- old/lolcat.c
++++ new/lolcat.c
+@@ -45,9 +45,9 @@
+ " lolcat Copy standard input to standard output.\n"
+ " fortune | lolcat Display a rainbow cookie.\n"
+ "\n"
+- "Report lolcat bugs to <http://www.github.org/jaseg/lolcat/issues>\n"
+- "lolcat home page: <http://www.github.org/jaseg/lolcat/>\n"
+- "Original idea: <http://www.github.org/busyloop/lolcat/>\n";
++ "Report lolcat bugs to <http://www.github.com/jaseg/lolcat/issues>\n"
++ "lolcat home page: <http://www.github.com/jaseg/lolcat/>\n"
++ "Original idea: <http://www.github.com/busyloop/lolcat/>\n";
+
+ #define ARRAY_SIZE(foo) (sizeof(foo) / sizeof(foo[0]))
+ const unsigned char codes[] = { 39, 38, 44, 43, 49, 48, 84, 83, 119, 118, 154, 148, 184, 178, 214, 208, 209, 203, 204, 198, 199, 163, 164, 128, 129, 93, 99, 63, 69, 33 };
+@@ -72,7 +72,7 @@
+
+ static void version(void)
+ {
+- wprintf(L"lolcat version 0.1, (c) 2014 jaseg\n");
++ wprintf(L"lolcat version 1.0, (c) 2014 jaseg\n");
+ exit(0);
+ }
+