aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libsexy/APKBUILD21
1 files changed, 10 insertions, 11 deletions
diff --git a/main/libsexy/APKBUILD b/main/libsexy/APKBUILD
index 6ad08dda443..7055666efff 100644
--- a/main/libsexy/APKBUILD
+++ b/main/libsexy/APKBUILD
@@ -1,36 +1,35 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsexy
pkgver=0.1.11
-pkgrel=7
+pkgrel=8
pkgdesc="Doing naughty things to good widgets."
url="http://chipx86.com/wiki/Libsexy"
arch="all"
-license="GPL"
+options="!check" # Tests require manual intervention and X11 display.
+license="LGPL-2.0+"
subpackages="$pkgname-dev $pkgname-doc"
makedepends="gtk+2.0-dev libxml2-dev iso-codes-dev"
source="http://releases.chipx86.com/$pkgname/$pkgname/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ cd "$builddir"
+ update_config_sub
+ default_prepare
}
build ()
{
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="$pkgdir" install
rm -f "$pkgdir"/usr/lib/libsexy.a
}