aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/wlroots/APKBUILD11
-rw-r--r--community/wlroots/meson-disabler-workaround.patch24
2 files changed, 5 insertions, 30 deletions
diff --git a/community/wlroots/APKBUILD b/community/wlroots/APKBUILD
index af77ca9184b..9c001a62e7e 100644
--- a/community/wlroots/APKBUILD
+++ b/community/wlroots/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=wlroots
-pkgver=0.8.1
-pkgrel=1
+pkgver=0.10.0
+pkgrel=0
pkgdesc="A modular Wayland compositor library"
url="https://github.com/swaywm/wlroots"
arch="all"
@@ -26,8 +26,7 @@ makedepends="
xkeyboard-config
"
subpackages="$pkgname-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$pkgver.tar.gz
- meson-disabler-workaround.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$pkgver.tar.gz"
build() {
meson \
@@ -35,6 +34,7 @@ build() {
--libdir /usr/lib \
-Dlogind=enabled \
-Dlogind-provider=elogind \
+ -Dexamples=false \
. build
ninja -C build
}
@@ -43,5 +43,4 @@ package() {
DESTDIR="$pkgdir" ninja -C build install
}
-sha512sums="da41513de48e00303b31fde620463389103215011c6cc49b9a2420a1529889722aa54f26a211179c528709edb6b90ba2efdae5e4bcef18147d9516f3a94e365a wlroots-0.8.1.tar.gz
-6163fb91ee1ab24acb3188f5abf866e4f55a3dac0a366dcd1050a0a72d1f4cad78df09b162a9128659cf00180c3174462de5150827f448be8b1d1becdd0894de meson-disabler-workaround.patch"
+sha512sums="0e8e0c37f1afb1d99f0ecb3c2282992ffd06381aaa396c7234ead9f3ff2d5c599e766b677680ebaecf68e792054c3e42657d24f32d08bc8bcf35f9eb4bdaa876 wlroots-0.10.0.tar.gz"
diff --git a/community/wlroots/meson-disabler-workaround.patch b/community/wlroots/meson-disabler-workaround.patch
deleted file mode 100644
index 37d0609fbe0..00000000000
--- a/community/wlroots/meson-disabler-workaround.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 3a62a43ef758ec4d973032a9aaeb6ed8d1be630e Mon Sep 17 00:00:00 2001
-From: Simon Ser <contact@emersion.fr>
-Date: Tue, 8 Oct 2019 19:33:19 +0300
-Subject: [PATCH] build: workaround for meson disabler object not working with
- if not
-
----
- examples/meson.build | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/examples/meson.build b/examples/meson.build
-index 8a60e1edd..869384c29 100644
---- a/examples/meson.build
-+++ b/examples/meson.build
-@@ -20,7 +20,8 @@ foreach dep : ['libpng', 'libavutil', 'libavcodec', 'libavformat']
- endif
- endforeach
-
--if not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
-+# Check if libavutil is found because of https://github.com/mesonbuild/meson/issues/6010
-+if libavutil.found() and not cc.has_header('libavutil/hwcontext_drm.h', dependencies: libavutil)
- libavutil = disabler()
- endif
-