aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libpcap/APKBUILD6
-rw-r--r--main/libpcap/disable-remote.patch30
2 files changed, 34 insertions, 2 deletions
diff --git a/main/libpcap/APKBUILD b/main/libpcap/APKBUILD
index b51809f82e9..a88a384d87a 100644
--- a/main/libpcap/APKBUILD
+++ b/main/libpcap/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libpcap
pkgver=1.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="A system-independent interface for user-level packet capture"
url="http://www.tcpdump.org/"
arch="all"
@@ -10,6 +10,7 @@ depends=
options="!check"
makedepends="bison flex autoconf linux-headers"
source="http://www.tcpdump.org/release/$pkgname-$pkgver.tar.gz
+ disable-remote.patch
"
subpackages="$pkgname-doc $pkgname-dev"
builddir="$srcdir"/$pkgname-$pkgver
@@ -37,4 +38,5 @@ package() {
make -j1 DESTDIR="$pkgdir" install install-shared
}
-sha512sums="bff5ff53fe53324f423e38eb4062c3fbb9125f86ca90d5e88aca9f0b3da72bc0acc6221c022b0f88cb3f000267580719119824c388da545c6f35117660cbb53b libpcap-1.8.1.tar.gz"
+sha512sums="bff5ff53fe53324f423e38eb4062c3fbb9125f86ca90d5e88aca9f0b3da72bc0acc6221c022b0f88cb3f000267580719119824c388da545c6f35117660cbb53b libpcap-1.8.1.tar.gz
+3e5d47793ad154da7bc42b9b249288cd4c84bf545baa5d49b2fb8b0626c87305ed6e07006a62767db2cda045103343844042655603d85f2679fff83fda00b3b8 disable-remote.patch"
diff --git a/main/libpcap/disable-remote.patch b/main/libpcap/disable-remote.patch
new file mode 100644
index 00000000000..91a94e9a51a
--- /dev/null
+++ b/main/libpcap/disable-remote.patch
@@ -0,0 +1,30 @@
+Disable bits of remote capture support inherited from the WinPCAP merge
+which cause applications to fail to build if they define HAVE_REMOTE (#843384).
+
+Patch-Source: https://sources.debian.net/src/libpcap/1.8.1-3/debian/patches/disable-remote.diff/
+--- a/pcap/pcap.h
++++ b/pcap/pcap.h
+@@ -506,6 +506,11 @@
+ #define MODE_STAT 1
+ #define MODE_MON 2
+
++#ifdef HAVE_REMOTE
++ /* Includes most of the public stuff that is needed for the remote capture */
++ #include <remote-ext.h>
++#endif /* HAVE_REMOTE */
++
+ #elif defined(MSDOS)
+
+ /*
+@@ -526,11 +531,6 @@
+
+ #endif /* _WIN32/MSDOS/UN*X */
+
+-#ifdef HAVE_REMOTE
+- /* Includes most of the public stuff that is needed for the remote capture */
+- #include <remote-ext.h>
+-#endif /* HAVE_REMOTE */
+-
+ #ifdef __cplusplus
+ }
+ #endif