aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libsndfile/APKBUILD5
-rw-r--r--main/libsndfile/CVE-2018-19758.patch13
2 files changed, 17 insertions, 1 deletions
diff --git a/main/libsndfile/APKBUILD b/main/libsndfile/APKBUILD
index d8b9f067810..6cc76e7dd2f 100644
--- a/main/libsndfile/APKBUILD
+++ b/main/libsndfile/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libsndfile
pkgver=1.0.28
-pkgrel=5
+pkgrel=6
pkgdesc="A C library for reading and writing files containing sampled sound"
url="http://www.mega-nerd.com/libsndfile"
arch="all"
@@ -22,6 +22,9 @@ source="http://www.mega-nerd.com/$pkgname/files/$pkgname-$pkgver.tar.gz
[ "$CARCH" = "armhf" ] && options="!check"
# secfixes:
+# 1.0.28-r6:
+# - CVE-2018-19758
+# - CVE-2019-3832
# 1.0.28-r5:
# - CVE-2017-17456
# - CVE-2017-17457
diff --git a/main/libsndfile/CVE-2018-19758.patch b/main/libsndfile/CVE-2018-19758.patch
new file mode 100644
index 00000000000..7b4e9477bb6
--- /dev/null
+++ b/main/libsndfile/CVE-2018-19758.patch
@@ -0,0 +1,13 @@
+--- a/src/wav.c.orig
++++ b/src/wav.c
+@@ -1094,6 +1094,10 @@
+ psf_binheader_writef (psf, "44", 0, 0) ; /* SMTPE format */
+ psf_binheader_writef (psf, "44", psf->instrument->loop_count, 0) ;
+
++ /* Make sure we don't read past the loops array end. */
++ if (psf->instrument->loop_count > ARRAY_LEN (psf->instrument->loops))
++ psf->instrument->loop_count = ARRAY_LEN (psf->instrument->loops) ;
++
+ for (tmp = 0 ; tmp < psf->instrument->loop_count ; tmp++)
+ { int type ;
+