aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/qt-creator/APKBUILD10
-rw-r--r--testing/qt-creator/fix-execinfo.patch22
-rw-r--r--testing/qt-creator/fix-malloc-trim.patch2
3 files changed, 17 insertions, 17 deletions
diff --git a/testing/qt-creator/APKBUILD b/testing/qt-creator/APKBUILD
index cc73f5f8115..606d91336f3 100644
--- a/testing/qt-creator/APKBUILD
+++ b/testing/qt-creator/APKBUILD
@@ -2,8 +2,8 @@
# Contributor: Alexey Minnekhanov <alexeymin@postmarketos.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt-creator
-pkgver=5.0.2
-pkgrel=1
+pkgver=6.0.0
+pkgrel=0
pkgdesc="Lightweight and cross-platform C++ IDE"
url="https://qt-project.org/wiki/Category:Tools::QtCreator"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
@@ -55,7 +55,7 @@ package() {
}
sha512sums="
-a2111f0687fa2177a5c0b7c4a8768544d5f63b1aa7b53e1d1f9dcc69fc49a00f12399f988da35b1243de9d690d23aa05029d4385ea3882014a56b022a4a0e447 qt-creator-opensource-src-5.0.2.tar.xz
-2265351131763da0454d08d72e0370ed70901c333a56eb566c5463c04fa8c2d2577b539fc7d0b1e0ad1b0229de9b343a1b610f59c4c41d13beb786bfbe213f62 fix-execinfo.patch
-009efcc9532ad3d8a26b9b44f31e6a8f82c87359aca5ff1943caed8b9fc53cdee81a8256b082602804435410bf8c4df795c06993a49ef42a5910b5c34057aee9 fix-malloc-trim.patch
+4d97b18cb5ad8388f3ea0f1cff3b4d0cb04251d2dba22770a7d9f387efbe670b9461a8d83e08a92aefb6472c36e19d0902ff42fd85fd224318b99c66d2526bbb qt-creator-opensource-src-6.0.0.tar.xz
+702f014fc99bfba2576aa7459890afaad430638b2461059793884a3a527a05c73b58b649447e1f46b45c564f777aa7117581066b559dac896d082381057ef1b0 fix-execinfo.patch
+4fbb9ad60622983c3ffb5600d374e76c2e21d1d8e1f0da255932c9c2e828c14ccc61c4065dd8cceff74088565a08f39685b29b9e2f767fc09773ac1ae89c4b60 fix-malloc-trim.patch
"
diff --git a/testing/qt-creator/fix-execinfo.patch b/testing/qt-creator/fix-execinfo.patch
index b409a30afd7..f9bf5662222 100644
--- a/testing/qt-creator/fix-execinfo.patch
+++ b/testing/qt-creator/fix-execinfo.patch
@@ -1,6 +1,6 @@
---- a/src/plugins/debugger/shared/backtrace.cpp
-+++ b/src/plugins/debugger/shared/backtrace.cpp
-@@ -30,8 +30,10 @@
+--- a/src/libs/utils/qtcassert.cpp
++++ b/src/libs/utils/qtcassert.cpp
+@@ -31,8 +31,10 @@
#if defined(Q_OS_LINUX)
#include <stdio.h>
#include <signal.h>
@@ -8,18 +8,18 @@
#include <execinfo.h>
#endif
+#endif
-
- namespace Debugger {
- namespace Internal {
+
+ namespace Utils {
+
@@ -40,7 +42,7 @@ void dumpBacktrace(int maxdepth)
{
if (maxdepth == -1)
- maxdepth = 200;
--#if defined(Q_OS_LINUX)
-+#if defined(Q_OS_LINUX) && defined(__GLIBC__)
- void *bt[200] = {nullptr};
- qDebug() << "BACKTRACE:";
+ maxdepth = 1000;
+-#if defined(Q_OS_UNIX)
++#if defined(Q_OS_UNIX) && defined(__GLIBC__)
+ void *bt[1000] = {nullptr};
int size = backtrace(bt, sizeof(bt) / sizeof(bt[0]));
+ char **lines = backtrace_symbols(bt, size);
diff --git a/src/plugins/qmldesigner/designercore/exceptions/exception.cpp b/src/plugins/qmldesigner/designercore/exceptions/exception.cpp
index a3a9806f7e..c369e681ab 100644
--- a/src/plugins/qmldesigner/designercore/exceptions/exception.cpp
diff --git a/testing/qt-creator/fix-malloc-trim.patch b/testing/qt-creator/fix-malloc-trim.patch
index e699c3021ec..144494f4bcf 100644
--- a/testing/qt-creator/fix-malloc-trim.patch
+++ b/testing/qt-creator/fix-malloc-trim.patch
@@ -2,7 +2,7 @@ diff --git a/src/app/main.cpp b/src/app/main.cpp
index 248fa8efef..4c27f65625 100644
--- a/src/app/main.cpp
+++ b/src/app/main.cpp
-@@ -782,7 +782,7 @@ int main(int argc, char **argv)
+@@ -741,7 +741,7 @@ int main(int argc, char **argv)
// shutdown plugin manager on the exit
QObject::connect(&app, &QCoreApplication::aboutToQuit, &pluginManager, &PluginManager::shutdown);