aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/mkcal/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/mkcal/APKBUILD b/community/mkcal/APKBUILD
index 24669533791..8022c2c2c64 100644
--- a/community/mkcal/APKBUILD
+++ b/community/mkcal/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=mkcal
-pkgver=0.5.47
+pkgver=0.6.7
pkgrel=0
pkgdesc="The mobile version of the original KCAL from KDE"
url="https://github.com/sailfishos/mkcal"
@@ -15,16 +15,17 @@ depends_dev="
"
makedepends="$depends_dev
doxygen
- graphviz
extra-cmake-modules
+ graphviz
+ samurai
"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://github.com/sailfishos/mkcal/archive/$pkgver/mkcal-$pkgver.tar.gz"
options="!check" # Broken and requires running DBus server
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_PLUGINS=OFF \
@@ -47,5 +48,5 @@ tools() {
amove usr/bin/mkcaltool
}
sha512sums="
-788838f74e7a5c4f447344b486fc4017a7de26cd97dfd6c837328dc6845784c5ce1b3a0d4f158203f52cb907976814bbd047542439b4a57f1e3740e4471b7ca6 mkcal-0.5.47.tar.gz
+0f9dea103721f593c056e7f5ff7de6e155e840292c6d152d8582e027f88693f472f9fc06fbf0ad7be67360cded83935b67d13446de1215dbb88076ae42349cb4 mkcal-0.6.7.tar.gz
"