aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/wlopm/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/wlopm/APKBUILD b/testing/wlopm/APKBUILD
new file mode 100644
index 00000000000..5976fc118dc
--- /dev/null
+++ b/testing/wlopm/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Nulo <alpine@nulo.in>
+# Maintainer: Nulo <alpine@nulo.in>
+pkgname=wlopm
+pkgver=0_git20220103
+_commit=06ae5c5f6efbea3ffe058dc1c5066c12e3019d33
+pkgrel=0
+pkgdesc="Wayland output power management"
+url="https://sr.ht/~leon_plickat/wlopm/"
+arch="all"
+license="GPL-3.0-or-later"
+options="!check" # No test suite
+makedepends="wayland-dev"
+subpackages="$pkgname-doc"
+source="$pkgname-$_commit.tar.gz::https://git.sr.ht/~leon_plickat/wlopm/archive/$_commit.tar.gz"
+builddir="$srcdir/$pkgname-$_commit"
+
+build() {
+ make
+}
+
+package() {
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
+sha512sums="
+2c9b1bff911772294927190dbc46529199cc4dff47680467b7242e7dd5b54fcd371a554599a9e236161aa9638ee895032ff5c88e1cc607a79d668171f1b38e0c wlopm-06ae5c5f6efbea3ffe058dc1c5066c12e3019d33.tar.gz
+"