aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/emacs/APKBUILD2
-rw-r--r--community/gcc6/APKBUILD7
-rw-r--r--community/ghc/APKBUILD8
-rw-r--r--community/java-gcj-compat/APKBUILD3
-rw-r--r--community/libreoffice/APKBUILD1
-rw-r--r--community/midori/APKBUILD2
-rw-r--r--community/qemu/APKBUILD2
-rw-r--r--community/quassel/APKBUILD3
-rw-r--r--community/sbcl/APKBUILD4
-rw-r--r--community/webkit2gtk/APKBUILD3
10 files changed, 7 insertions, 28 deletions
diff --git a/community/emacs/APKBUILD b/community/emacs/APKBUILD
index 0498dea434a..a8aee90091f 100644
--- a/community/emacs/APKBUILD
+++ b/community/emacs/APKBUILD
@@ -9,7 +9,7 @@ arch="all !s390x !mips !mips64"
depends="emacs-nox"
url="https://www.gnu.org/software/emacs/emacs.html"
license="GPL-3.0-or-later"
-makedepends="autoconf automake linux-headers paxmark gawk
+makedepends="autoconf automake linux-headers gawk
librsvg-dev giflib-dev libxpm-dev gtk+2.0-dev gtk+3.0-dev alsa-lib-dev
glib-dev fontconfig-dev libpng-dev
libxml2-dev pango-dev tiff-dev libjpeg-turbo-dev ncurses-dev
diff --git a/community/gcc6/APKBUILD b/community/gcc6/APKBUILD
index f910e3cfee4..f1edadafd85 100644
--- a/community/gcc6/APKBUILD
+++ b/community/gcc6/APKBUILD
@@ -10,7 +10,7 @@ arch="all !mips !mips64" # FTBFS on mips
license="GPL LGPL"
_gccrel=$pkgver-r$pkgrel
depends="binutils isl"
-makedepends_build="gcc$_cross g++$_cross paxmark bison flex texinfo gawk zip gmp-dev mpfr-dev mpc1-dev zlib-dev"
+makedepends_build="gcc$_cross g++$_cross bison flex texinfo gawk zip gmp-dev mpfr-dev mpc1-dev zlib-dev"
makedepends_host="linux-headers gmp-dev mpfr-dev mpc1-dev isl-dev zlib-dev !gettext-dev"
subpackages="$pkgname-doc"
@@ -237,8 +237,6 @@ package() {
mkdir -p "$pkgdir"/usr/share/gdb/python/auto-load/usr/$gdblib
mv "$i" "$pkgdir"/usr/share/gdb/python/auto-load/usr/$gdblib/
done
-
- paxmark -pmrs "$pkgdir"/$_gcclibexec/cc1
}
libcxx() {
@@ -257,7 +255,6 @@ gpp() {
"$subpkgdir"/$_gcclibdir/include
mv "$pkgdir/$_gcclibexec/cc1plus" "$subpkgdir/$_gcclibexec/"
- paxmark -pmrs "$subpkgdir/$_gcclibexec/cc1plus"
mv "$pkgdir"/$_gcclibdir/*++* "$subpkgdir"/$_gcclibdir/
mv "$pkgdir"/$_gcclibdir/include/c++ "$subpkgdir"/$_gcclibdir/include/
@@ -268,7 +265,6 @@ java() {
pkgdesc="Java support for GCC"
depends="zlib-dev gcc6=$_gccrel libgcj6=$_gccrel"
- paxmark -pm "$pkgdir"/$_gcclibexec/ecj1
mkdir -p "$subpkgdir"/usr/bin "$subpkgdir"/usr/lib "$subpkgdir"/$_gcclibdir/
cd "$pkgdir"/usr/bin
mv gcj-$_ver gcj-dbtool-$_ver gjavah-$_ver gcjh-$_ver jcf-dump-$_ver "$subpkgdir"/usr/bin/
@@ -293,7 +289,6 @@ libgcj() {
mkdir -p "$subpkgdir"/usr/bin
cd "$pkgdir"/usr/bin
- paxmark -pmse "$pkgdir"/usr/bin/gij-$_ver
mv aot-compile-$_ver gappletviewer-$_ver gc-analyze-$_ver gij-$_ver \
gjar-$_ver gjarsigner-$_ver gkeytool-$_ver gnative2ascii-$_ver gorbd-$_ver \
grmic-$_ver grmid-$_ver grmiregistry-$_ver gserialver-$_ver \
diff --git a/community/ghc/APKBUILD b/community/ghc/APKBUILD
index e0be3cfa3c3..9f876e532b6 100644
--- a/community/ghc/APKBUILD
+++ b/community/ghc/APKBUILD
@@ -27,7 +27,7 @@ depends="gmp-dev perl gcc>=6.2.1 llvm$_llvmver libffi-dev"
# ghc is self-hosted, so we need ghc to build ghc. ghc-bootstrap is provided by
# this aport (see below).
makedepends_build="$pkgname-bootstrap
- autoconf cpio binutils binutils-gold paxmark libffi-dev ncurses-dev xz coreutils grep"
+ autoconf cpio binutils binutils-gold libffi-dev ncurses-dev xz coreutils grep"
makedepends_host="linux-headers musl-dev zlib-dev gmp-dev binutils-dev libffi-dev ncurses-dev cpio" # need GNU cpio
makedepends="$makedepends_build $makedepends_host"
checkdepends="python3"
@@ -164,12 +164,6 @@ package() {
find . -type f \( -name "*.so" -o -name "*.a" \) \
-exec ${CROSS_COMPILE}strip --strip-unneeded {} \;
find $ghclib/bin -type f -exec ${CROSS_COMPILE}strip {} \;
-
- paxmark -m \
- $ghclib/bin/ghc \
- $ghclib/bin/ghc-iserv \
- $ghclib/bin/ghc-iserv-dyn \
- $ghclib/bin/ghc-iserv-prof
}
# Like debian, we split apart the profiled archives/etc...
diff --git a/community/java-gcj-compat/APKBUILD b/community/java-gcj-compat/APKBUILD
index bec54e3562d..864bb6a4ab8 100644
--- a/community/java-gcj-compat/APKBUILD
+++ b/community/java-gcj-compat/APKBUILD
@@ -13,7 +13,7 @@ url="https://git.alpinelinux.org/aports.git"
arch="all !mips !mips64"
license="GPL-2.0-or-later"
depends="fastjar gcc6-java=$_gccver-r$_gccpkgrel java-common"
-makedepends="gcc6-java=$_gccver-r$_gccpkgrel zlib-dev paxmark"
+makedepends="gcc6-java=$_gccver-r$_gccpkgrel zlib-dev"
prepare() {
(
@@ -31,7 +31,6 @@ build() {
gcj-6 -Wl,-Bsymbolic -findirect-dispatch -o ecj \
--main=org.eclipse.jdt.internal.compiler.batch.Main \
/usr/share/java/ecj.jar -lgcj
- paxmark -msp ecj
}
check() {
diff --git a/community/libreoffice/APKBUILD b/community/libreoffice/APKBUILD
index 0a45fa9b215..3f6fc35001d 100644
--- a/community/libreoffice/APKBUILD
+++ b/community/libreoffice/APKBUILD
@@ -75,7 +75,6 @@ makedepends="
openjdk8
openldap-dev
openssl-dev
- paxmark
perl
perl-archive-zip
poppler-dev
diff --git a/community/midori/APKBUILD b/community/midori/APKBUILD
index 5c280bf85e9..d89151e49e6 100644
--- a/community/midori/APKBUILD
+++ b/community/midori/APKBUILD
@@ -6,7 +6,7 @@ pkgdesc="lightweight web browser based on Gtk WebKit"
url="https://www.midori-browser.org"
arch="all !s390x !mips !mips64" # librsvg
license="LGPL-2.1-or-later"
-makedepends="cmake librsvg-dev paxmark python3 vala gtk+3.0-dev gcr-dev
+makedepends="cmake librsvg-dev python3 vala gtk+3.0-dev gcr-dev
libarchive-dev libunique-dev json-glib-dev webkit2gtk-dev libpeas-dev
ninja"
subpackages="$pkgname-lang $pkgname-doc"
diff --git a/community/qemu/APKBUILD b/community/qemu/APKBUILD
index b38762cd1a5..b74e8c35708 100644
--- a/community/qemu/APKBUILD
+++ b/community/qemu/APKBUILD
@@ -33,7 +33,6 @@ makedepends="
linux-headers
lzo-dev
ncurses-dev
- paxmark
perl
pulseaudio-dev
python3
@@ -304,7 +303,6 @@ package() {
cd "$builddir"/build
make DESTDIR="$pkgdir" install
- paxmark -m "$pkgdir"/usr/bin/qemu-system-*
install -Dm640 -g qemu "$srcdir"/bridge.conf \
"$pkgdir"/etc/qemu/bridge.conf
diff --git a/community/quassel/APKBUILD b/community/quassel/APKBUILD
index 08b84d68d20..aa16bb1bf7b 100644
--- a/community/quassel/APKBUILD
+++ b/community/quassel/APKBUILD
@@ -17,7 +17,7 @@ depends_client="$pkgname-common"
depends_mono="$pkgname-common"
depends_server="$pkgname-common qt5-qtbase-postgresql qt5-qtbase-sqlite"
depends_server_openrc=""
-makedepends="cmake paxmark dbus-dev icu-dev openldap-dev openssl-dev
+makedepends="cmake dbus-dev icu-dev openldap-dev openssl-dev
qca-dev qt5-qtbase-dev qt5-qtscript-dev zlib-dev
"
source="https://www.quassel-irc.org/pub/$pkgname-$pkgver.tar.bz2
@@ -55,7 +55,6 @@ package() {
cd "$builddir"
make -C build DESTDIR="$pkgdir" install/fast
- paxmark -m "$pkgdir"/usr/bin/quasselcore
install -Dm0644 "$srcdir"/quasselcore.confd \
"$pkgdir"/etc/conf.d/quasselcore
diff --git a/community/sbcl/APKBUILD b/community/sbcl/APKBUILD
index e63421af088..2b5113fbb57 100644
--- a/community/sbcl/APKBUILD
+++ b/community/sbcl/APKBUILD
@@ -11,7 +11,7 @@ arch="x86 x86_64 armv7 aarch64"
license="custom"
options="!check"
checkdepends="ed"
-makedepends="ecl ecl-dev gmp-dev gc gc-dev libffi-dev linux-headers paxmark zlib-dev"
+makedepends="ecl ecl-dev gmp-dev gc gc-dev libffi-dev linux-headers zlib-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.bz2::https://prdownloads.sourceforge.net/sbcl/sbcl-$pkgver-source.tar.bz2
Fix-ARM-build-using-ECL-host.patch
@@ -35,8 +35,6 @@ package() {
DOC_DIR="$pkgdir/usr/share/doc/$pkgname" \
sh install.sh
- paxmark -rm "$pkgdir"/usr/bin/sbcl
-
install -Dm644 COPYING \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE.txt
diff --git a/community/webkit2gtk/APKBUILD b/community/webkit2gtk/APKBUILD
index bda479b8607..57432713bd3 100644
--- a/community/webkit2gtk/APKBUILD
+++ b/community/webkit2gtk/APKBUILD
@@ -41,7 +41,6 @@ makedepends="
openjpeg-dev
openjpeg-tools
pango-dev
- paxmark
python3
ruby
samurai
@@ -232,8 +231,6 @@ check() {
package() {
DESTDIR="$pkgdir" ninja -C "$builddir"/build install
- # needed for JIT
- paxmark -m "$pkgdir"/usr/libexec/webkit2gtk-4.0/WebKitWebProcess
}
sha512sums="406fc767a806bb2af446c73e7079720a4d82d592a95a20f30f468c31cdc2efd25e082a5ecfbe00c27f62236e1e56a729c48191451d130188419967975378235d webkitgtk-2.30.5.tar.xz