aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/ruby-mathematical/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/ruby-mathematical/APKBUILD b/community/ruby-mathematical/APKBUILD
index c5998e3a816..b9eacd59a7a 100644
--- a/community/ruby-mathematical/APKBUILD
+++ b/community/ruby-mathematical/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ruby-mathematical
_gemname=${pkgname#ruby-}
-pkgver=1.6.12
-pkgrel=5
+pkgver=1.6.13
+pkgrel=0
pkgdesc="Convert mathematical equations to SVGs, PNGs, or MathML"
url="https://www.gjtorikian.com/mathematical/"
arch="all !aarch64 !s390x !mips !mips64" # Limited by lasem
@@ -29,8 +29,6 @@ prepare() {
}
build() {
- cd "$builddir"
-
gem build $_gemname.gemspec
gem install --local \
--install-dir dist \
@@ -44,7 +42,6 @@ build() {
check() {
local dev_deps
- cd "$builddir"
# Install missing development dependencies needed and used only for running
# tests. We can't install them easily with bundler, because there's
@@ -68,8 +65,8 @@ package() {
# Remove unnecessary files and rubbish...
find "$gemdir"/extensions/ -name mkmf.log -delete
cd "$gemdir"/gems/$_gemname-$pkgver
- rm -r ext/ test/ Rakefile *.md *.txt || true
+ rm -rf -- ext/ test/ Rakefile *.md *.txt
}
-sha512sums="f3b3362a63b2fc6dfb1e4f1e44142bc26fd9487f46c3b146b6279948f0153ad7c40f75c09bf19058be183546a57631d091ebcf289b88db3d981a24ff0bbee05a ruby-mathematical-1.6.12.tar.gz
+sha512sums="16ec5e4da958e0851237fc3d1f1b26e82e14e0ce48a3955eed0e8630d9781652b192559667448a44662c94ac5844658cba39712b734a90c30bb51098ed2bf39c ruby-mathematical-1.6.13.tar.gz
35c691b2006e6c0bac26ebb0adac5ffa99fbc37100c94d5978508b91b3df84544e4fc8fa38b5de01ae0fcc644c1eeb97b6129f59b4488b467c1ded468277c400 use-system-mtex2mml-fixtures.patch"