aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/dnstwist/APKBUILD14
1 files changed, 13 insertions, 1 deletions
diff --git a/testing/dnstwist/APKBUILD b/testing/dnstwist/APKBUILD
index d53752d5613..dcfe02bcc73 100644
--- a/testing/dnstwist/APKBUILD
+++ b/testing/dnstwist/APKBUILD
@@ -2,13 +2,15 @@
# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
pkgname=dnstwist
pkgver=20201022
-pkgrel=0
+pkgrel=1
pkgdesc="Domain name permutation engine"
url="dnstwist.it"
arch="noarch"
license="Apache-2.0"
depends="python3 py3-requests py3-dnspython py3-tld"
makedepends="py3-setuptools"
+subpackages="$pkgname-dictionaries"
+
source="$pkgname-$pkgver.tar.gz::https://github.com/elceef/dnstwist/archive/$pkgver.tar.gz"
build() {
@@ -23,4 +25,14 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
+dictionaries() {
+ pkgdesc="Dictionaries for dnstwist"
+ depends=""
+
+ mkdir -p "$subpkgdir"/usr/share/dnstwist/dictionaries
+ for dict in "$builddir"/dictionaries/*.dict; do
+ install -Dm0644 "$dict" "$subpkgdir"/usr/share/dnstwist/dictionaries/"$(basename $dict)"
+ done
+}
+
sha512sums="0eaf3cb297eea899bdd431eb88e79e95d6288c8786f07227285275b27692f871c6c36a67251603f1b1d4d2f60eab177d1b8478bd5be74f3d317a47eedf58db3e dnstwist-20201022.tar.gz"