aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--main/libdnet/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/main/libdnet/APKBUILD b/main/libdnet/APKBUILD
index 8d6324a3787..f7b9bc620ed 100644
--- a/main/libdnet/APKBUILD
+++ b/main/libdnet/APKBUILD
@@ -1,18 +1,18 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libdnet
pkgver=1.12
-pkgrel=7
+pkgrel=8
pkgdesc="A simplified, portable interface to several low-level networking routines"
url="https://github.com/dugsong/libdnet"
arch="all"
-license="BSD"
+license="BSD-3-Clause"
subpackages="$pkgname-dev $pkgname-doc"
makedepends="autoconf automake bash libtool linux-headers"
-source="https://github.com/dugsong/libdnet/archive/$pkgname-$pkgver.tar.gz
+source="https://github.com/dugsong/libdnet/archive/libdnet-$pkgver.tar.gz
automake.patch
"
-
builddir="$srcdir"/$pkgname-$pkgname-$pkgver
+
prepare() {
default_prepare
# the libtool script does not add .so extention to we generate
@@ -22,7 +22,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,7 +32,6 @@ build() {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}