aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/nextcloud/APKBUILD30
-rw-r--r--community/nextcloud/nextcloud-app-encryption-info-add-mcrypt.patch2
2 files changed, 16 insertions, 16 deletions
diff --git a/community/nextcloud/APKBUILD b/community/nextcloud/APKBUILD
index 29af04aa68a..3d3a4b8add3 100644
--- a/community/nextcloud/APKBUILD
+++ b/community/nextcloud/APKBUILD
@@ -1,8 +1,9 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
pkgname=nextcloud
-pkgver=20.0.5
+pkgver=21.0.0
pkgrel=0
+_replaced_ver=20
pkgdesc="A safe home for all your data"
url="http://nextcloud.com"
arch="noarch"
@@ -25,12 +26,13 @@ provides="$pkgname-contactsinteraction=$pkgver-r$pkgrel
$pkgname-viewer=$pkgver-r$pkgrel
$pkgname-workflowengine=$pkgver-r$pkgrel
"
+replaces="nextcloud$_replaced_ver"
install="$pkgname.pre-install $pkgname.pre-upgrade $pkgname.post-upgrade
$pkgname-initscript.post-install"
subpackages="$pkgname-doc $pkgname-initscript $pkgname-mysql $pkgname-pgsql $pkgname-sqlite
$pkgname-default-apps:_default_apps"
source="https://download.nextcloud.com/server/releases/nextcloud-$pkgver.zip
- nextcloud19-dont-chmod.patch
+ nextcloud-dont-chmod.patch
nextcloud-app-encryption-info-add-mcrypt.patch
dont-update-htaccess.patch
disable-integrity-check-as-default.patch
@@ -152,6 +154,7 @@ package() {
}
doc() {
+ replaces="nextcloud${_replaced_ver}-doc"
default_doc
local target="$subpkgdir"/usr/share/webapps/$pkgname/core/doc
@@ -162,6 +165,7 @@ doc() {
initscript() {
pkgdesc="Init script that runs Nextcloud with php-fpm"
depends="$pkgname $_php-fpm"
+ replaces="nextcloud${_replaced_ver}-initscript"
local confdir="$subpkgdir/etc/$_php/php-fpm.d"
local fpm_name="php-fpm${_php#php}"
@@ -179,24 +183,28 @@ initscript() {
pgsql() {
pkgdesc="Nextcloud PostgreSQL support"
depends="$pkgname $_php-pgsql $_php-pdo_pgsql"
+ replaces="nextcloud${_replaced_ver}-pgsql"
mkdir -p "$subpkgdir"
}
sqlite() {
pkgdesc="Nextcloud SQLite support"
depends="$pkgname $_php-sqlite3 $_php-pdo_sqlite"
+ replaces="nextcloud${_replaced_ver}-sqlite"
mkdir -p "$subpkgdir"
}
mysql() {
pkgdesc="Nextcloud MySQL support"
depends="$pkgname $_php-pdo_mysql"
+ replaces="nextcloud${_replaced_ver}-mysql"
mkdir -p "$subpkgdir"
}
_default_apps() {
pkgdesc="Nextcloud default apps"
depends="$pkgname"
+ replaces="nextcloud${_replaced_ver}-default-apps"
local path; for path in "$pkgdir"/$_appsdir/*; do
if grep -q '<default_enable\s*/>' "$path"/appinfo/info.xml; then
@@ -213,6 +221,7 @@ _package_app() {
local name=$(xmlstarlet sel -t -v 'info/name/text()' "$appinfo")
pkgdesc="Nextcloud ${name:-$appname} app"
+ replaces="nextcloud${_replaced_ver}-${appname}"
local php_deps=$(xmlstarlet sel -t -v 'info/dependencies/lib/text()' "$appinfo" \
| xargs -r -n1 printf "$_php-%s\n")
@@ -226,16 +235,7 @@ _package_app() {
photos)
app_deps="-viewer"
provides="$pkgname-gallery=$pkgver-r$pkgrel"
- ;;
-
- # XXX: Provides/replaces for backward compatibility with <12.0.0-r2.
- files_pdfviewer | files_videoplayer)
- provides="$pkgname-${appname#files_}"
- replaces="$provides"
- ;;
- user_ldap)
- provides="$pkgname-ldap"
- replaces="$provides"
+ replaces="$replaces nextcloud${_replaced_ver}-gallery"
;;
esac
@@ -245,9 +245,9 @@ _package_app() {
mv "$pkgdir"/$_appsdir/$appname "$subpkgdir"/$_appsdir/
}
-sha512sums="81527827f9d9a57c768e57286896b788ec1ba2ce9b871b26b86dd6d69bfaf486c2b4fb74e72ff09a7bad031535e7c28f530945a0a0f5439b2f3f32dccc211a33 nextcloud-20.0.5.zip
-aea0adb2c3a48ec6af2958c6ccfe13adff86316a56084e763b7e6df9e21aa3435b13305b7c15cc2b795e83c9388b05006862f6465c29e3dc2c1fbd8eb8befcb9 nextcloud19-dont-chmod.patch
-2d03b90c1e2f3d96001f31f1bbf902e4c411c8de7dc5a4f956fa8297533324cb12092d3ad2198f2e02ff4835dc22febee2d49e449b003caef5b990d9dcff1e70 nextcloud-app-encryption-info-add-mcrypt.patch
+sha512sums="665675dead97e36c952d449f7b0f8913a40836da3bde333018e55156d714ce113d69b3dd1bc36c344ada2bcd7c39e72b2ba1b10e825d5110088f59387be97d7b nextcloud-21.0.0.zip
+aea0adb2c3a48ec6af2958c6ccfe13adff86316a56084e763b7e6df9e21aa3435b13305b7c15cc2b795e83c9388b05006862f6465c29e3dc2c1fbd8eb8befcb9 nextcloud-dont-chmod.patch
+67654d1b606c36ee9a8804b4ae0c9310c6f9dbc38aee0e73afb8da535fe64ee688b7052fd5d248ce094843c54dd8858e8c4cb014556a5a33f261fd3a4d56f7c4 nextcloud-app-encryption-info-add-mcrypt.patch
aef3c92497d738d6968e0f0b0d415b4953500db24ae14af41ef972665cf7eff00cb6c53dc953845fdbb389c3c965a75b8b14b9247513c05cf4130fe1cfc61731 dont-update-htaccess.patch
d2100a837fef1eeae5f706650ab4c985d9e00f61efa5526ef76c7c1f5811c3906eb6c3c13c151eff9677a0c303faab64411a5a84d6792728bc520d2c618d7d5b disable-integrity-check-as-default.patch
3fc3e06580a619d81b12f448976ffac34f0bb80fc73e9443fa213a73f160ba4b9bd14a26c134258ee12c04d8e103b46f4de10d7b11e4544a328878e57d436055 iconv-ascii-translit-not-supported.patch
diff --git a/community/nextcloud/nextcloud-app-encryption-info-add-mcrypt.patch b/community/nextcloud/nextcloud-app-encryption-info-add-mcrypt.patch
index d926ee0a60a..9572ff30c78 100644
--- a/community/nextcloud/nextcloud-app-encryption-info-add-mcrypt.patch
+++ b/community/nextcloud/nextcloud-app-encryption-info-add-mcrypt.patch
@@ -7,6 +7,6 @@ index 5050996..6df2d2b 100644
<dependencies>
<lib>openssl</lib>
+ <lib>mcrypt</lib>
- <nextcloud min-version="20" max-version="20"/>
+ <nextcloud min-version="21" max-version="21"/>
</dependencies>