aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/tomahawk/APKBUILD25
-rw-r--r--community/tomahawk/qtkeychain.patch13
2 files changed, 28 insertions, 10 deletions
diff --git a/community/tomahawk/APKBUILD b/community/tomahawk/APKBUILD
index 205fd98b499..027390ff5d6 100644
--- a/community/tomahawk/APKBUILD
+++ b/community/tomahawk/APKBUILD
@@ -2,36 +2,40 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=tomahawk
pkgver=0.8.4
-pkgrel=7
+pkgrel=8
pkgdesc="A Music Player App written in C++/Qt"
url="http://tomahawk-player.org/"
arch="all"
license="GPL3"
+options="!check" #upstream does not provide check
depends="phonon-backend-gstreamer qt-sqlite"
-depends_dev="qt-dev phonon-dev boost-dev gnutls-dev qtkeychain-dev
- libechonest-dev lucene++-dev taglib-dev qca-dev attica-dev quazip-dev
+makedepends="cmake sparsehash websocket++ automoc4
+ linux-headers bsd-compat-headers
+ qt-dev phonon-dev boost-dev gnutls-dev
+ libechonest-dev lucene++-dev taglib-dev
+ qca-dev attica-dev quazip-dev
liblastfm-dev qtkeychain-dev jreen-dev"
-makedepends="$depends_dev cmake sparsehash websocket++ automoc4 linux-headers
- bsd-compat-headers"
subpackages="$pkgname-dev"
source="http://download.tomahawk-player.org/tomahawk-$pkgver.tar.bz2
musl-fixes.patch
compare-taglib-version.patch
+ qtkeychain.patch
"
-
builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ default_prepare
+ mkdir -p "$builddir"/build
+}
+
build() {
- mkdir "$builddir"/build
cd "$builddir"/build
cmake "$builddir" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
- -DFORCE_QT4=ON \
-DCMAKE_INSTALL_LIBEXECDIR=lib/${pkgname} \
-DBUILD_SHARED_LIBS=True \
-DCMAKE_BUILD_TYPE=Release
-
}
package() {
@@ -41,4 +45,5 @@ package() {
sha512sums="5b312f593eac39d06de05e24d4ce429122d0777a9d52d6db8c65309ac283d7ae560c2fc189b186f0f8b1a7bbe1135ed0d59e1d850de6a93655e53efe4f5317c7 tomahawk-0.8.4.tar.bz2
eaf3a13d6e664999820aa562921462ca51e3abea464fd4fba3864ac9cac723b13fa5d349feea88a4c44356348bab127dda0899fb6335e610a8e4f5172d55b1d9 musl-fixes.patch
-a09e7d4e9bc684ca51714795716dd1756e490c2824371824313f53b0f0008c5fcfe95bceefd237d8d9c2b553760639848251770140739bc401b77a2b4e44c77c compare-taglib-version.patch"
+a09e7d4e9bc684ca51714795716dd1756e490c2824371824313f53b0f0008c5fcfe95bceefd237d8d9c2b553760639848251770140739bc401b77a2b4e44c77c compare-taglib-version.patch
+8042084030a624dc2eea4e4ef79259f7f25858a62b39dda3b795aff0c330e25dc936d00a7a395a6cb6e9c3e347be7bf0aa077c1ca108aeb0a423dbe90933f213 qtkeychain.patch"
diff --git a/community/tomahawk/qtkeychain.patch b/community/tomahawk/qtkeychain.patch
new file mode 100644
index 00000000000..bb9666af39e
--- /dev/null
+++ b/community/tomahawk/qtkeychain.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3180626..102b8c8 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -324,7 +324,7 @@ if( TOMAHAWK_QT5 )
+ else()
+ macro_optional_find_package(QtKeychain 0.1.0)
+ endif()
+-macro_log_feature(QTKEYCHAIN_FOUND "QtKeychain" "Provides support for secure credentials storage" "https://github.com/frankosterfeld/qtkeychain" TRUE "" "")
++macro_log_feature(QtKeychain_FOUND "QtKeychain" "Provides support for secure credentials storage" "https://github.com/frankosterfeld/qtkeychain" TRUE "" "")
+ endif()
+
+ if( UNIX AND NOT APPLE )