aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/php8/APKBUILD10
-rw-r--r--community/php8/content-encoding.patch42
-rw-r--r--community/php8/fix-curl-7.83-test.patch25
3 files changed, 30 insertions, 47 deletions
diff --git a/community/php8/APKBUILD b/community/php8/APKBUILD
index 84cb779496b..f17ef61f102 100644
--- a/community/php8/APKBUILD
+++ b/community/php8/APKBUILD
@@ -25,8 +25,8 @@
pkgname=php8
_pkgreal=php
-pkgver=8.0.18
-pkgrel=1
+pkgver=8.0.19
+pkgrel=0
_apiver=20200930
_suffix=${pkgname#php}
# Is this package the default (latest) PHP version?
@@ -101,7 +101,7 @@ source="https://php.net/distributions/$_pkgreal-$pkgver.tar.xz
fix-tests-devserver.patch
xfail-openssl-1.1-test.patch
atomic-lsapi.patch
- content-encoding.patch
+ fix-curl-7.83-test.patch
"
builddir="$srcdir/$_pkgreal-$pkgver"
@@ -619,7 +619,7 @@ _mv() {
}
sha512sums="
-fda43f5bcb2aba7c2777331b41d2d8bb35c0b8508feef1a2fbff15105acfd7a41e0a4f1f9111e5cf1091e5df04ac4c737ec939c5bd5d85535b3b3ebb0450bc21 php-8.0.18.tar.xz
+106aa7c9f4804b8ce3518d7e6da4dc8f2a4df2f0b5d7369776737e0b13d4cd6be375694b78271fd1d007d4e0892009dc2a7214c1652462ebf128b74f845787e8 php-8.0.19.tar.xz
8a9a63cddfd9bdde23db85a7be0711e14688bab35b580abd0184d370c54de80b72cbdeb369570cd23927154984f024eaad5d222d53d9e19130fb2e8758dd4540 php8-fpm.initd
cd3a96d3febde3b6657ed80ff58945641443e84e5e0fd3d9df29e640e9549bc452a3412f1999fa02ae1ee2b64c08040998fa75805f67e0252741c376e26e1c3c php8-fpm.logrotate
95f536addfbb28fbca8b14da46d95a3595369d6e98d345f55f0fda1b12bdefd1579a27505424e7d1088a987d330798253cec9bd42b544bb567189cba746217c7 php8-module.conf
@@ -631,5 +631,5 @@ f634ac591576dff87487d239578420364edb56e977535c4a5ab799d360a799179edf1e7e6a4e6b6e
1b64a7cef9e81387f955cb60ffa4e3d2277b4f6072e9328d779c0d447c202c8ee9dff0d8d8c34abc82c150311f51c4e9316a3b72a383ca6c9a6e683bc5b349a0 fix-tests-devserver.patch
996b9a542858b0385a300265194afc57eddb72b9d7e4dcdf63b4f1ba7d3588e67309030acc73f00af1717168becd50b1d3582fcb88605e9892fd683a33cae023 xfail-openssl-1.1-test.patch
465b38c089d938a4a072b2eff3edaf928455bf873f5eeb65ff3bee9614f5f45c70f285abb50809c2e2d9d259395acae38bd649860ca3b8d65e43447082a51552 atomic-lsapi.patch
-c703c56d8b0de2da15fa23212c31a5058fdad283a1fb7a31c9755ccdde3555d21c28c78a6f68286a28f5afa590719a8ea4bf61937ae311ec1b0145c1ed33639b content-encoding.patch
+be6a57063414bd255def54d5f6e42cbdc3baec55c8eaf9c8ca6e96d0cb3fec942ebb1868806850859d34c5c45d03a2abfec3fecd1aef04524da8eda01d9041ed fix-curl-7.83-test.patch
"
diff --git a/community/php8/content-encoding.patch b/community/php8/content-encoding.patch
deleted file mode 100644
index 313985faf35..00000000000
--- a/community/php8/content-encoding.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From 792012885d1926ffc96bed3280e7e9560a54a9ad Mon Sep 17 00:00:00 2001
-From: "Christoph M. Becker" <cmbecker69@gmx.de>
-Date: Tue, 12 Apr 2022 17:18:00 +0200
-Subject: [PATCH] Fix GH-8218: ob_end_clean does not reset Content-Encoding
- header
-
-Patch-source: https://github.com/php/php-src/pull/8353
-
-The fix for GH-7953 introduced a regression by being to deliberate
-adding the respective headers. These must only be added, if the
-handler starts, but is not finalizing.
----
- ext/iconv/iconv.c | 2 +-
- ext/zlib/zlib.c | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/ext/iconv/iconv.c b/ext/iconv/iconv.c
-index 7a66c965e3cb..f23aa90f52db 100644
---- a/ext/iconv/iconv.c
-+++ b/ext/iconv/iconv.c
-@@ -311,7 +311,7 @@ static int php_iconv_output_handler(void **nothing, php_output_context *output_c
- mimetype = SG(default_mimetype) ? SG(default_mimetype) : SAPI_DEFAULT_MIMETYPE;
- }
-
-- if (mimetype != NULL && (!(output_context->op & PHP_OUTPUT_HANDLER_CLEAN) || (output_context->op & PHP_OUTPUT_HANDLER_START))) {
-+ if (mimetype != NULL && (!(output_context->op & PHP_OUTPUT_HANDLER_CLEAN) || ((output_context->op & PHP_OUTPUT_HANDLER_START) && !(output_context->op & PHP_OUTPUT_HANDLER_FINAL)))) {
- size_t len;
- char *p = strstr(get_output_encoding(), "//");
-
-diff --git a/ext/zlib/zlib.c b/ext/zlib/zlib.c
-index f7cf0d5dac76..774a31e18cd4 100644
---- a/ext/zlib/zlib.c
-+++ b/ext/zlib/zlib.c
-@@ -281,7 +281,7 @@ static int php_zlib_output_handler(void **handler_context, php_output_context *o
- return FAILURE;
- }
-
-- if (!(output_context->op & PHP_OUTPUT_HANDLER_CLEAN) || (output_context->op & PHP_OUTPUT_HANDLER_START)) {
-+ if (!(output_context->op & PHP_OUTPUT_HANDLER_CLEAN) || ((output_context->op & PHP_OUTPUT_HANDLER_START) && !(output_context->op & PHP_OUTPUT_HANDLER_FINAL))) {
- int flags;
-
- if (SUCCESS == php_output_handler_hook(PHP_OUTPUT_HANDLER_HOOK_GET_FLAGS, &flags)) {
diff --git a/community/php8/fix-curl-7.83-test.patch b/community/php8/fix-curl-7.83-test.patch
new file mode 100644
index 00000000000..b087acfb28a
--- /dev/null
+++ b/community/php8/fix-curl-7.83-test.patch
@@ -0,0 +1,25 @@
+From a4179e4c92b6365d39e09cb9cd63c476848013af Mon Sep 17 00:00:00 2001
+From: "Christoph M. Becker" <cmbecker69@gmx.de>
+Date: Wed, 27 Apr 2022 12:37:39 +0200
+Subject: [PATCH] Fix test for curl 7.83.0
+Patch-Source: https://github.com/php/php-src/commit/a4179e4c92b6365d39e09cb9cd63c476848013af
+
+libcurl 7.83.0 removed some trailing exclamation marks from error
+messages[1]; we have to cater to that.
+
+[1] <https://github.com/curl/curl/commit/6968fb9d54dc3a1aaa1b16088f038eaf5dd8b2d7>
+---
+ ext/curl/tests/curl_basic_007.phpt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/ext/curl/tests/curl_basic_007.phpt b/ext/curl/tests/curl_basic_007.phpt
+index 3b53658d6a7e..3834e4674f82 100644
+--- a/ext/curl/tests/curl_basic_007.phpt
++++ b/ext/curl/tests/curl_basic_007.phpt
+@@ -20,5 +20,5 @@ curl_close($ch);
+
+ ?>
+ --EXPECTF--
+-string(%d) "No URL set!%w"
++string(%d) "No URL set%A"
+ int(3)