aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--community/gnome-2048/APKBUILD15
-rw-r--r--community/gnome-2048/meson.patch38
2 files changed, 48 insertions, 5 deletions
diff --git a/community/gnome-2048/APKBUILD b/community/gnome-2048/APKBUILD
index 6b4ce25c77c..baa9c0cebc5 100644
--- a/community/gnome-2048/APKBUILD
+++ b/community/gnome-2048/APKBUILD
@@ -2,16 +2,18 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome-2048
pkgver=3.38.2
-pkgrel=1
-arch="all"
-url="https://wiki.gnome.org/Apps/2048"
+pkgrel=2
pkgdesc="Obtain the 2048 tile"
+url="https://wiki.gnome.org/Apps/2048"
license="GPL-3.0-or-later"
+arch="all"
makedepends="meson ninja itstool vala gtk+3.0-dev clutter-dev clutter-gtk-dev
libgee-dev libgnome-games-support-dev"
checkdepends="appstream-glib desktop-file-utils"
-source="https://download.gnome.org/sources/gnome-2048/${pkgver%.*}/gnome-2048-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+source="https://download.gnome.org/sources/gnome-2048/${pkgver%.*}/gnome-2048-$pkgver.tar.xz
+ meson.patch
+ "
build() {
abuild-meson . output
@@ -26,4 +28,7 @@ package() {
DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="9063c31ef2a1126b92b6f52950237ac3878a8cbe4b1304e2c56e4bc7f8b99320f45ad27b3d7be3fb4cd2a1856bd11a171facc98bc917076118b83380668e4df8 gnome-2048-3.38.2.tar.xz"
+sha512sums="
+9063c31ef2a1126b92b6f52950237ac3878a8cbe4b1304e2c56e4bc7f8b99320f45ad27b3d7be3fb4cd2a1856bd11a171facc98bc917076118b83380668e4df8 gnome-2048-3.38.2.tar.xz
+a4603aab87fca8928d2194b5189dd4baeaab8f95f4fda9e306d1124f02ce44327734482c998f813e8232b26cb40b00ad33a7defc502e43eeaa3b3f4ac5546302 meson.patch
+"
diff --git a/community/gnome-2048/meson.patch b/community/gnome-2048/meson.patch
new file mode 100644
index 00000000000..8ba3655d01a
--- /dev/null
+++ b/community/gnome-2048/meson.patch
@@ -0,0 +1,38 @@
+Patch-Source: https://gitlab.gnome.org/GNOME/gnome-2048/-/merge_requests/21
+
+From 194e22699f7166a016cd39ba26dd719aeecfc868 Mon Sep 17 00:00:00 2001
+From: Jan Beich <jbeich@FreeBSD.org>
+Date: Sun, 23 Jan 2022 10:49:07 +0000
+Subject: [PATCH] meson: drop unused argument for i18n.merge_file()
+
+Ignored in Meson < 0.60.0, deprecated since 0.60.1 and fatal since 0.61.0.
+
+data/meson.build:19:0: ERROR: Function does not take positional arguments.
+data/meson.build:39:0: ERROR: Function does not take positional arguments.
+---
+ data/meson.build | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/data/meson.build b/data/meson.build
+index 33f73ca..8974a63 100644
+--- a/data/meson.build
++++ b/data/meson.build
+@@ -17,7 +17,6 @@ install_data(
+
+ # Desktop file
+ desktop_file = i18n.merge_file(
+- 'desktop-file',
+ input: 'org.gnome.TwentyFortyEight.desktop.in',
+ output: 'org.gnome.TwentyFortyEight.desktop',
+ install: true,
+@@ -37,7 +36,6 @@ endif
+
+ # AppData file
+ appdata_file = i18n.merge_file(
+- 'appdata-file',
+ input: 'org.gnome.TwentyFortyEight.appdata.xml.in',
+ output: 'org.gnome.TwentyFortyEight.appdata.xml',
+ install: true,
+--
+GitLab
+