aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--testing/sublime-music/APKBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/testing/sublime-music/APKBUILD b/testing/sublime-music/APKBUILD
index 8e7712d1741..0c053112590 100644
--- a/testing/sublime-music/APKBUILD
+++ b/testing/sublime-music/APKBUILD
@@ -1,26 +1,33 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=sublime-music
-pkgver=0.11.10
-pkgrel=1
+pkgver=0.11.13
+pkgrel=0
pkgdesc="A native, GTK3 Subsonic client for the Linux Desktop"
url="https://sublimemusic.app"
arch="all !s390x !ppc64le" # py3-mpv doesnt work on these
options="!check" # tests fail
-license="GPL-3.0-only"
+license="GPL-3.0-or-later"
depends="python3 py3-bleach py3-dataclasses-json py3-dateutil py3-deepdiff py3-fuzzywuzzy
py3-gobject3 py3-levenshtein py3-mpv py3-peewee py3-requests py3-semver py3-pychromecast
py3-bottle py3-keyring libnotify"
-makedepends="py3-setuptools"
+makedepends="py3-pip poetry"
source="sublime-music-$pkgver.tar.gz::https://gitlab.com/sumner/sublime-music/-/archive/v$pkgver/sublime-music-v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-v$pkgver"
build() {
- python3 setup.py build
+ # poetry is buggy and doesn't include python source files if it is built in
+ # the default directory...?
+ mkdir -p /tmp/$pkgname && cp -r . /tmp/$pkgname && cd /tmp/$pkgname
+ poetry build --format wheel
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m pip install \
+ --no-warn-script-location --ignore-installed --no-deps --root="$pkgdir" \
+ /tmp/$pkgname/dist/sublime_music-$pkgver-py3-none-any.whl
}
-sha512sums="8da2e4287c976cc798e364229dc4636cc81ad3c4632785097e38b1f65d10d659922b9b6565e8b270e5fe514678fca10849571509463c09919b8121a0e0bde711 sublime-music-0.11.10.tar.gz"
+sha512sums="
+813778e35fcb2d83da7da6c1f514b49a321314ebcbff8c524141857e0643426b1bc8a8739171605bec389f3077c6e343e1b9183ac3c981b79f00668eb2d9ce37 sublime-music-0.11.13.tar.gz
+"